Bug 190278 - comical 0.8 contains non-Free unrar code
comical 0.8 contains non-Free unrar code
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: comical (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-29 23:49 EDT by Kevin Kofler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 17:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2006-04-29 23:49:05 EDT
Description of problem:
According to the specfile, comical used to call external unrar and unzip tools 
for decompression. Unfortunately, newer versions moved to including the 
decompression libraries directly. (Check the contents of your SRPM...) This is 
a problem because unrar has the following restrictions:
   2. The unRAR sources may be used in any software to handle RAR
      archives without limitations free of charge, but cannot be used
      to re-create the RAR compression algorithm, which is proprietary.
      Distribution of modified unRAR sources in separate form or as a
      part of other software is permitted, provided that it is clearly
      stated in the documentation and source comments that the code may
      not be used to develop a RAR (WinRAR) compatible archiver.
   3. The unRAR utility may be freely distributed. No person or company
      may charge a fee for the distribution of unRAR without written
      permission from the copyright holder.
Neither of these is acceptable for Fedora Extras. Unrar itself isn't currently 
in Extras either: it's available from Livna, indicating that the packager 
considered it unacceptable for Extras too. And the comical FE specfile itself 
also says that unrar isn't acceptable for Extras.
(Note that the "Requires: unzip" is also redundant due to this change.)

Version-Release number of selected component (if applicable):
comical-0.8-1.fc5
Comment 1 Tom "spot" Callaway 2006-05-01 10:39:53 EDT
These are very valid points, I didn't even catch that. Looks like this package
is going into Livna. :/
Comment 2 Kevin Kofler 2006-08-06 21:41:33 EDT
http://rpm.livna.org/fedora/5/i386/repodata/repoview/comical-0-0.8-2.lvn5.html

Now can someone request removal from Extras?
Comment 3 Tom "spot" Callaway 2006-08-22 17:43:21 EDT
Comical is gone from Extras. Closing.

Note You need to log in before you can comment on or make changes to this bug.