Bug 190281 - Spurious dependency on python-setuptools?
Spurious dependency on python-setuptools?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-kid (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 04:50 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 14:05:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-04-30 04:50:22 EDT
Is the install time dependency (Requires:) on python-setuptools in python-kid
actually needed for something?  Quick grepping around doesn't reveal anything,
and for example repoview runs quite happily without python-setuptools installed.
Comment 1 Konstantin Ryabitsev 2006-05-01 14:05:37 EDT
It's required, sadly -- take a look at /usr/bin/kid*. I could have patched it
out, but it's easier to just pull in python-setuptools, since they are going to
be increasingly requried by python egg packages anyway.

Please reopen if that doesn't address your concern.
Comment 2 Ville Skyttä 2006-05-01 14:39:39 EDT
Oh, I missed that /usr/bin stuff.  No problem then, sorry about the noise.

Note You need to log in before you can comment on or make changes to this bug.