Bug 190296 - telnet should not use gethostbyname
Summary: telnet should not use gethostbyname
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: telnet (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-30 17:33 UTC by Ulrich Drepper
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 07:26:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replace last two gethostbyname uses (1.49 KB, patch)
2006-04-30 17:33 UTC, Ulrich Drepper
no flags Details | Diff

Description Ulrich Drepper 2006-04-30 17:33:59 UTC
Description of problem:
telnet still uses gethostbyname.  This can cause problems in IPv6 environments,
in part due to the way gethostbyname etc are implemented.

Version-Release number of selected component (if applicable):
0.17-35.2.1

How reproducible:
always

Steps to Reproduce:
1.nm -D --undef /usr/bin/telnet | fgrep gethostbyname
2.
3.
  
Actual results:
                 U gethostbyname


Expected results:
No output

Additional info:
The attached mostly untested patch should fix it.  For real IPv6 support a lot
more work is needed.

Comment 1 Ulrich Drepper 2006-04-30 17:33:59 UTC
Created attachment 128417 [details]
Replace last two gethostbyname uses


Note You need to log in before you can comment on or make changes to this bug.