Bug 190300 - openoffice writer does not display hebrew documents
Summary: openoffice writer does not display hebrew documents
Status: CLOSED DUPLICATE of bug 200805
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-30 18:38 UTC by Pavel Rosenboim
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.0.2-5.9.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 08:35:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Document that is not displayed properly. (35.50 KB, application/msword)
2006-04-30 18:38 UTC, Pavel Rosenboim
no flags Details
screenshot (76.26 KB, image/png)
2006-05-01 15:25 UTC, Caolan McNamara
no flags Details
That's how document looks (54.60 KB, image/jpeg)
2006-05-02 10:41 UTC, Pavel Rosenboim
no flags Details
my /etc/fonts dir (8.07 KB, application/x-bzip)
2006-05-12 11:36 UTC, Pavel Rosenboim
no flags Details

Description Pavel Rosenboim 2006-04-30 18:38:12 UTC
Description of problem:
Openoffice writer does not display documents in hebrew. Empty spaces are
displayed instead of hebrew letters

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.2-5.7.2 and openoffice.org-writer-2.0.2-5.8.2

How reproducible:
Always.

Steps to Reproduce:
1. Open any documents with hebrew text. Either openoffice (.odt) or MS word
document.
2.
3.
  
Actual results:
Empty spaces or boxes are displayed instead of hebrew text.

Expected results:
Display document

Additional info:

Comment 1 Pavel Rosenboim 2006-04-30 18:38:13 UTC
Created attachment 128420 [details]
Document that is not displayed properly.

Comment 2 Caolan McNamara 2006-05-01 15:25:42 UTC
Created attachment 128446 [details]
screenshot

Here's how it looks for me. Is this correct ? I assume you have a different
appearance ? if so do you have fonts-hebrew installed ? If you have
openoffice.org-langpack-langpack-he_IL installed that should have pulled in
those hebrew fonts as a dependancy.

> rpm -q fonts-hebrew

Comment 3 Caolan McNamara 2006-05-01 15:27:01 UTC
Please advise, is your problem visible in my screeshot ?

Comment 4 Pavel Rosenboim 2006-05-02 10:41:37 UTC
Created attachment 128477 [details]
That's how document looks

Comment 5 Pavel Rosenboim 2006-05-02 10:44:49 UTC
On your screenshot the document looks correctly. I attached my screenshot. 
I do have openoffice.org-langpack-langpack-he_IL and fonts-hebrew, as well as
fonts-hebrew-fancy installed.

Also, after I added some windows fonts, the document display became correct.
Yet, I tried it with Ubuntu (LiveCD) without windows fonts and it displays
correctly there.

Comment 6 Caolan McNamara 2006-05-03 07:27:57 UTC
On a stock FC-5 with "fonts-hebrew" installed and latest update 2.0.2-5.9.2 all
is well for me

Comment 7 Pavel Rosenboim 2006-05-06 12:48:09 UTC
Still doesn't work here.

Comment 8 Caolan McNamara 2006-05-09 14:56:43 UTC
I can't reproduce this, Ideally you could help out by removing all your non
fedora-core fonts except for fonts-hebrew and verify that it is still broken
after stopping and restarting OOo.

Or if it is not broken, add back the removed font packages until the font which
causes the problem is revealed. Presumably copying the broken text from oowriter
into gedit does not show the problem ?

Comment 9 Pavel Rosenboim 2006-05-09 15:15:44 UTC
Ok. The problem is fonts-hebrew-fancy from the extras. If I remove them,
document is displayed fine, with or without windows TTF fonts.

Comment 10 Caolan McNamara 2006-05-10 11:39:24 UTC
frustratingly if I install fonts-hebrew and fonts-hebrew-fancy on my stock fc-5
box I still don't have a problem with this document and openoffice.org-2.0.2-9.2

what does 

> fc-match 'Arial':lang=he

say ?

Comment 11 Pavel Rosenboim 2006-05-10 12:00:11 UTC
I tried it in few combinations:
When only fonts-hebrew and fonts-hebrew-fancy installed (without windows fonts,
document is garbled):
ComixNo2CLM-Medium.pfa: "Comix No2 CLM" "Medium"

With fonts-hebrew and windows fonts (got same result, no matter whether
fonts-hebrew-fancy installed or not, document looks ok):
arial.ttf: "Arial" "Regular"

Only fonts-hebrew installed (document looks ok):
FrankRuehlCLM-Medium.pfa: "Frank Ruehl CLM" "Medium"

Comment 12 Caolan McNamara 2006-05-12 11:02:41 UTC
Still no luck, have you customized your /etc/fonts in any way ? if so can I get
a tarball of /etc/fonts ?

Comment 13 Pavel Rosenboim 2006-05-12 11:36:28 UTC
Created attachment 128933 [details]
my /etc/fonts dir

No, as far as I know.

Comment 14 Caolan McNamara 2006-08-03 08:35:39 UTC
The glyph fallback order must be the same problem here as it was in bug 200805.
That would explain this font-dependant behaviour

*** This bug has been marked as a duplicate of 200805 ***


Note You need to log in before you can comment on or make changes to this bug.