Bug 190326 - hdparm -d 1 /dev/hdc says HDIO_SET_DMA failed: Operation not permitted using_dma = 0 (off)
hdparm -d 1 /dev/hdc says HDIO_SET_DMA failed: Operation not permitted using_...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 04:01 EDT by kb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 05:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kb 2006-05-01 04:01:53 EDT
Description of problem:
when using default startup for FC5 (grup.conf):
kernel /vmlinuz-2.6.16-1.2096_FC5 ro root=LABEL=/ rhgb quiet

one cannot change DMA settings for CD/DVD-unit.
running
hdparm -d 1 /dev/hdc

gives error:
HDIO_SET_DMA failed: Operation not permitted using_dma = 0 (off)



Version-Release number of selected component (if applicable):
hdparm v6.3

How reproducible:
see above.


Actual results:
The DMA setting is not changabe.

Expected results:
The DMA should be changable.

Additional info:
Starting up the system using extra parameters:
hdc=noprobe, seems to set the device in DMA mode.

I can help with extra information, but please specify what i should do if you
need more info from me.
Comment 1 kb 2006-05-01 04:02:27 EDT
kernel i use is: 2.6.16-1.2096_FC5.
Comment 2 Karsten Hopp 2006-05-22 05:40:30 EDT
is your CD/DVD drive connected with a 80-wire cable ? It looks like can't use DMA 
with 40-wire cables.

Note You need to log in before you can comment on or make changes to this bug.