This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 19033 - XFree86 4.0.1 creates large logfiles
XFree86 4.0.1 creates large logfiles
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 05:37 EDT by dxw
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 19:54:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dxw 2000-10-13 05:37:42 EDT
The extmod module keeps putting the following in the log file
/var/log/XFree86.0.log

GetModeLine - scrn: 0 clock: 108000
GetModeLine - hdsp: 1280 hbeg: 1328 hend: 1440 httl: 1688
              vdsp: 1024 vbeg: 1025 vend: 1028 vttl: 1066 flags: 5

This happens once at startup, and continually while xscreensaver is active.

This has twice run my system out of disk space by increasing the size of
the log file by over 150M while the screen saver is on overnight.

I think it may also have something to do with me using the internal font
rendering modules instead of the font server (TrueType fonts refuse to
render when using the font server, XFree86 handles them).

Current XFree86 4.0.1 modules list from XF86Config-4:
Section "Module"
        Load  "GLcore"
        Load  "dbe"
        Load  "dri"
        Load  "extmod"
        Load  "glx"
        Load  "pex5"
        Load  "record"
        Load  "xie"
        Load  "v4l"
        Load  "speedo"
        Load  "type1"
#       Load  "xtt"
        Load  "freetype"
        Load  "bitmap"
EndSection

If xtt is active, instead of freetype, the log file increases more rapidly
due to this module reloading encodings modules all the time. The reloading
gets logged.

I have eliminated the problem for now by changing the X server line in
gdm.conf file:
0=/usr/bin/X11/X -logfile /dev/null

Please note, I never had this problem with RH6.1 + XFree86 4.0.1 that I
compiled myself. The log files always remained at a reasonable size.
Comment 1 Mike A. Harris 2001-04-06 19:53:56 EDT
Does the problem go away if you upgrade to the newest rawhide release
of XFRee86-4.0.3-5?
Comment 2 Mike A. Harris 2001-07-03 04:31:13 EDT
I don't see a problem here with my XFree86.  Logfiles are not overly large.
Additionally truetype fonts work just fine with xfs in 4.0.1, 4.0.3 for
me.

Note You need to log in before you can comment on or make changes to this bug.