Bug 190339 - gnome-screensaver 'Fast Switch User' depends on non-existent gdm.conf
gnome-screensaver 'Fast Switch User' depends on non-existent gdm.conf
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 09:23 EDT by Aaron Gaudio
Modified: 2008-03-18 14:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Gaudio 2006-05-01 09:23:14 EDT
Description of problem:
If I enable the 'Fast Switch User' option to gnome-screensaver via gconf, and
then lock my screen, moving the mouse or pressing the keyboard results in a
frozen unlock dialog (the dialog begins to appear, but locks up before any label
or button is displayed and doesn't accept input; this may be the same symptoms
as in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186444). 

After switching to a virtual terminal and manually killing gnome-screensaver,
then switching back to X, I notice on the terminal that I launched the
gnome-screensaver daemon from the following error message:

(gnome-screensaver-dialog:30087): Screensaver-Fast-User-Switch-CRITICAL **:
Could not parse GDM configuration file `/etc/X11/gdm/gdm.conf': No such file or
directory

On Fedora Core 5, there is no /etc/X11/gdm/gdm.conf (or even an /etc/X11/gdm
directory, since it's in /etc/gdm now, and uses a combination of
/usr/share/gdm/defaults.conf and /etc/gdm/custom.conf).

I haven't looked into the design of gnome-screensaver or anything, but it seems
like a bad idea to depend on another component's config file location/format.
Especially when simply running 'gdmflexiserver' from the command line seems to
do exactly what gnome-screensaver should be doing (starting a new gdm login window).

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.1-1.fc5.1

How reproducible:
Always

Steps to Reproduce:
1. In gconf, enable the key /apps/gnome-screensaver/user_switch_enabled
2. Activate gnome-screensaver.
3. Attempt to unlock the screensaver.
  
Actual results:
Unlock dialog freezes up, have to manually kill the gnome-screensaver process.
Error from gnome-screensaver indicates it was trying to parse the non-existent
/etc/X11/gdm/gdm.conf.

Expected results:
Unlock dialog doesn't freeze up, has a button to start a new login window (e.g.
as gdmflexiserver does).

Additional info:
Comment 1 Pedro Lamarão 2006-06-07 09:30:22 EDT
This doesn't happen anymore with an up to date Fedora Core 5.
Comment 2 Ray Strode [halfline] 2008-03-18 14:33:32 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.