Bug 190356 - [PATCH] encrypted fs
[PATCH] encrypted fs
Status: CLOSED DUPLICATE of bug 127378
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 11:56 EDT by Bill Nottingham
Modified: 2014-03-16 22:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-29 18:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-05-01 11:56:04 EDT
...
I made a patch for initscripts-7.93.24.EL, that adds support for
mounting encrypted devices at boot time. It uses dm-crypt & cryptsetup
for the encrypted filesystems.

It would be nice to get it upstream, so I've made a version of the patch
to suit initscripts-8.33.

It is available here:
http://patches.jethrocarr.com/initscripts-8.33-encryptedfs.patch

Unfortunately, I don't run fedora, so I haven't been able to give it a
proper test. However, there should be no problems with it.

I've also got some RPMS available here:
http://packages.jethrocarr.com/SRPMS/initscripts-8.33-1.1.jethrocarr.src.rpm
http://packages.jethrocarr.com/RPMS/i386/initscripts-8.33-1.1.jethrocarr.i386.rpm



if you have any questions/comments/requests, feel free to ask them. :-)

thanks,
--
Jethro Carr
Comment 1 Jethro Carr 2006-07-15 03:53:47 EDT
I have now tested the RPMS's above on Fedora Core 5 (now my main desktop). :-)

I fixed a problem with the patch for fedora, so you'll want to re-download them
if you already downloaded them.

They now work perfectly. :-)

cheers,
--
Jethro Carr
Comment 2 Miloslav Trmač 2006-07-29 18:57:45 EDT
Thanks for the patches.  A different encrypted filesystem support has been
added to rawhide initscripts, hopefully compatible with the Debian configuration
files.

*** This bug has been marked as a duplicate of 127378 ***

Note You need to log in before you can comment on or make changes to this bug.