Bug 190359 - testing patch to fix bug 211058 (gnome bug)
testing patch to fix bug 211058 (gnome bug)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 12:14 EDT by Trever Adams
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 21:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Glade part of patch (9.50 KB, patch)
2006-06-28 16:09 EDT, Trever Adams
no flags Details | Diff
Believed and tested good to add the check against future dates (15.98 KB, patch)
2006-06-28 22:46 EDT, Trever Adams
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 211058 None None None Never

  None (edit)
Description Trever Adams 2006-05-01 12:14:22 EDT
D. Malcom. I was wondering if you could help me test the patch included in the
following bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=211058

The patch should be valid against the latest evolution CVS and possibly older
version.

I have never had much luck trying to compile CVS evolution. I may not be reading
the code correctly, so if the patch doesn't allow you to catch bogus (future)
dates properly, I may have to reread the code (much more slowly this time) and
try again. If the patch works or doesn't please, if you wouldn't mind help me
get a working version included in CVS evolution, I would appreciate it.
Comment 1 Trever Adams 2006-06-28 13:56:35 EDT
Well, I stink with glade. "Ago" is coded as a label in filter.glade. I have
never quite figured out glade nor how to attach it to code. Is there any
RedHat/Fedora Core person who understands glade.

The changes needed are the label needs to become a drop down or some other
selection method. The options need to be "in the future" and "ago" if I
understand the code correctly (in that it creates a string that goes to the file
I patched). Then whatever the glade parsing/handling/callback code changes need
to be so that it fetches the value from the
selection/dropdown/whatever-method-chosen.

Of course, there are the maximum values in the code/patch I did. Somehow these
need to be brought in and parsed correctly for "in the future" options.

I am sorry, I just don't do a lot of gui programming and am still trying to learn.

Thank you much for any help anyone can provide.
Comment 2 Trever Adams 2006-06-28 15:14:50 EDT
MY NOTES - CURRENTLY TRYING MYSELF

Ok, my patch is completely bogus. Label8 in filter.glade needs to become a
selection with "ago" and "in the future" or similar labels with appropriate
translations. All the timespans with negative entries (i.e. mine) need to be
removed. All ago/in the future references in timespans need to be removed and
replaced with the selection mentioned above, with appropriate translations.

set_values must be modified to handle negative values by setting the lable8
replacement (option_past_future) correctly and to not set the spin to a negative
value as it is setup to ignore it.

get_values needs to be updated to use option_past_future

button_clicked needs to have stuff added for option_past_future

I think that is my total notes. Going to try to fetch the latest srpm and try to
build from that.
Comment 3 Trever Adams 2006-06-28 16:06:52 EDT
Matthew Barnes, I hope you don't mind that I am trying to add you as a cc here.
Below are some patches I am trying that appear to work. They supercede my other
patch (as it was completely broken).
Comment 4 Trever Adams 2006-06-28 16:09:11 EDT
Created attachment 131697 [details]
Glade part of patch

I am still working on the code part of this (having trouble compiling), but the
glade part is working it seems with the current evolution. I hope to have the
code diffed in about 40 minutes.
Comment 5 Dave Malcolm 2006-06-28 16:18:31 EDT
Does http://www.go-evolution.org/Compiling_Evolution_from_CVS help?

I'd suggest taking this to one of these mailing lists:
- evolution-hackers@gnome.org (intended for high-level discussion of development)
- evolution-patches@gnome.org (intended for patch review, can be quite terse)
- gnome-love@gnome.org (intended as a friendly place for people new to gnome
development looking to get involved)

Reassigning to Matt
Comment 6 Trever Adams 2006-06-28 22:45:30 EDT
Matt, I had several false starts. Lessons learned: rpmbuild's shortcircuit is
not the friend it appears to be... too bad.

This patch should be very clean other than one hack, but it is due to another
long-standing-hack already in the code.

Please, apply this to rawhide. I will work on getting it upstreamed.

One and a half questions: Is this a big enough change for me to add my name as
an author? Is it big enough to add my own copyright (under the GPL of course due
to my desires and the fact it is already such)?

This patch supercedes all others from me relating to this issue (that in 211058
that you included, and the glade one here).
Comment 7 Trever Adams 2006-06-28 22:46:54 EDT
Created attachment 131711 [details]
Believed and tested good to add the check against future dates

This patch obsoletes all others from me. It includes .h .c and .glade changes
necessary. Please, allow people to test this in rawhide, I will try to get it
upstreamed.
Comment 8 Trever Adams 2006-06-30 15:35:45 EDT
Evolution currently still has the old and broken patch. I am rebuilding today's
rawhide evolution changing the old patch for my new one, the patch does work.
Comment 9 Trever Adams 2006-07-10 23:54:18 EDT
Mr. Barnes, Evolution in rawhide still has a broken version (the initial try) of
my patch. Can you please remove it and replace it with the last one submitted
here. It works perfectly. Thank you. (Still trying to get it upstreamed.)
Comment 10 Matthew Barnes 2006-07-11 13:49:43 EDT
Done - evolution-2.7.3-10

Leaving this bug open until upstream accepts the patch.
Comment 11 Trever Adams 2006-11-04 12:46:09 EST
This patch seems to have fallen out of the latest evolution builds. Is there a
reason for that?
Comment 12 Matthew Miller 2007-04-06 13:41:04 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 13 Trever Adams 2007-04-07 18:01:19 EDT
This patch appears to have fallen out some how or no longer works. I will try to
verify which, but I believe it fell out. Still valid.
Comment 14 Matthew Miller 2007-04-08 14:29:51 EDT
Thanks.
Comment 15 Trever Adams 2007-09-23 20:58:19 EDT
I believe my patch or something similar has been upstreamed. Either way, I am no
longer maintaining the patch. Maybe this should be closed?
Comment 16 Matthew Barnes 2007-09-23 21:24:42 EDT
Yes, thanks for the reminder.  I believe your patch was accepted upstream.

Note You need to log in before you can comment on or make changes to this bug.