Bug 1903665 - Areca RAID firmware bug causes lsm.LocalDisk.get_link_type to induce low level corruption [rhel-7.9.z]
Summary: Areca RAID firmware bug causes lsm.LocalDisk.get_link_type to induce low leve...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.9
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 7.9
Assignee: Tony Asleson
QA Contact: ChanghuiZhong
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-02 15:31 UTC by Tony Asleson
Modified: 2021-09-03 14:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-16 13:56:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tony Asleson 2020-12-02 15:31:55 UTC
This bug was initially created as a copy of Bug #1903207

When querying a disk device link type the library causes Areca RAID controllers
to do very bad things.

Issues:
https://tracker.ceph.com/issues/48270
https://github.com/libstorage/libstoragemgmt/issues/442


Fix:
https://github.com/libstorage/libstoragemgmt/pull/444

Comment 4 ChanghuiZhong 2021-02-08 08:40:26 UTC
The reporter confirmed that this issue has been fixed by upstream,
https://tracker.ceph.com/issues/48270

QE lack Areca RAID equipment, so do sanity check,

Fix code has already involved in libstoragemgmt-1.8.1-2.el7_9:
$ git show 76611af879958d7ca62c0788fdfa92ef7f4a5ca8
commit 76611af879958d7ca62c0788fdfa92ef7f4a5ca8 (origin/rhel-7.9)
Author: Tony Asleson <tasleson@redhat.com>
Date:   Thu Feb 4 14:15:12 2021 -0600

    Use one-byte length for VPD inquiry commands
    
    Resolves: rhbz#1903665


Sanity test passed with libstoragemgmt-1.8.1-2.el7_9:
https://beaker.engineering.redhat.com/jobs/5077706
https://beaker.engineering.redhat.com/jobs/5076015
https://beaker.engineering.redhat.com/jobs/5075932

Move to verified + sanityonly

Comment 8 errata-xmlrpc 2021-03-16 13:56:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (libstoragemgmt bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0859


Note You need to log in before you can comment on or make changes to this bug.