Bug 1903786 - "Encrypt my data" checkbox disappears after selecting "Custom" storage configuration
Summary: "Encrypt my data" checkbox disappears after selecting "Custom" storage config...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: 8.0
Assignee: Vendula Poncova
QA Contact: Release Test Team
Alexandra Nikandrova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-02 18:59 UTC by Parikshit Khedekar
Modified: 2022-02-21 07:03 UTC (History)
11 users (show)

Fixed In Version: anaconda-33.16.5.2-1.el8
Doc Type: Bug Fix
Doc Text:
.Anaconda allows data encryption for automatically created disk layout in the custom partitioning screen Previously, requesting encrypted disk layout when the disk layout was automatically created in the custom partitioning screen was not possible. With this update, Anaconda provides an option on the custom partitioning screen to encrypt the automatically created disk layout.
Clone Of:
Environment:
Last Closed: 2021-11-09 18:42:11 UTC
Type: Bug
Target Upstream Version:
anikandr: needinfo+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4254 0 None None None 2021-11-09 18:42:34 UTC

Description Parikshit Khedekar 2020-12-02 18:59:37 UTC
Description of problem:

While performing a "from scratch" installation of RHEL 8.3 during the disk partitioning layout
setup. If you check "Custom" radio button the "Encrypt my data" radio button is hidden.

If you check the "Encrypt my data" radio button first and then check "Custom" radio button
the "Encrypt my data" radio button is hidden.

Selecting "Done" you get NO dialog for a passphrase.

Proceeding with custom layout and install the disk is NOT encrypted as desired.


It works fine with 8.2 and if I use a kickstart with line as following for 8.3 

part pv.236 --fstype="lvmpv" --ondisk=Xda --size=XXXXX --encrypted --luks-version=luks2 --passphrase=XXXXXXX


Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 8.3

How reproducible:

Always 

Steps to Reproduce:
1. Boot with RHEL 8.3 ISO
2. Select language
3. Select "Installation Destination"
4. Click on "Custom" radio button ( Checkbox for "Encrypt my data" disappears )
5. Click on "Automatic" radio button ( Checkbox for "Encrypt my data" appears )
6. Check the checkbox "Encrypt my data"  and click on "Custom" radio button again the Checkbox for "Encrypt my data" disappears
7. Create partitions but it won't ask for passphrase though I have selected the checkbox for "Encrypt my data"
8. And the install proceeds with no encryption set though we want to set.

Actual results:

No encryption set or passphrase asked

Expected results:

Should allow LUKS with custom partitioning.

Additional info:

Comment 1 Jan Stodola 2020-12-02 19:21:01 UTC
Workaround is to set encryption in the custom partitioning screen for the devices you want to have encrypted - anaconda will ask you for the passphrase when leaving the spoke.

I've updated the bug summary, since the custom partitioning spoke still allows to set encryption manually.

Comment 24 Marta Lewandowska 2021-06-29 13:26:32 UTC
Tested using anaconda-33.16.5.2-1.el8 in compose RHEL-8.5.0-20210626.d.0.
'Encrypt my data' check box is present in custom partitioning spoke and disappears once you "Click here to create them automatically"
If you want to encrypt data at this point instead, you can still click the Encrypt checkbox next to Device type.
Either way, you are asked to enter a passphrase when leaving the custom partitioning spoke.

Comment 33 errata-xmlrpc 2021-11-09 18:42:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (anaconda bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4254


Note You need to log in before you can comment on or make changes to this bug.