Bug 190379 - dnsmasq doesn't start
dnsmasq doesn't start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 16:16 EDT by JM
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.30-4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 19:29:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JM 2006-05-01 16:16:46 EDT
The version

dnsmasq-2.30-3.fc5.x86_64.rpm

is broken. I can't start it, I get always the message:

May  1 22:18:38 neo dnsmasq: ISC dhcpd integration not available: set
HAVE_ISC_READER in src/config.h
May  1 22:18:38 neo dnsmasq: FAILED to start up
Comment 1 Werner Hoelzl 2006-05-01 17:38:19 EDT
(In reply to comment #0)
> The version
> 
> dnsmasq-2.30-3.fc5.x86_64.rpm
> 
> is broken. I can't start it, I get always the message:
> 
> May  1 22:18:38 neo dnsmasq: ISC dhcpd integration not available: set
> HAVE_ISC_READER in src/config.h
> May  1 22:18:38 neo dnsmasq: FAILED to start up

The same problem occurs with FC4.
Comment 2 Jima 2006-05-01 19:29:01 EDT
See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189775#c5 ; that
message refers to a deprecated feature.  You need to configure dhcp-range and
dhcp-leasefile in /etc/dnsmasq.conf.

Upstream has been notified of this.

Marking as duplicate (otherwise NOTABUG).

*** This bug has been marked as a duplicate of 189775 ***
Comment 3 JM 2006-05-01 20:24:21 EDT
I don't use DHCPD from dnsmasq but I have to configure a dhcp-range and a
dhcp-leasefile? Btw. the default /etc/dnsmasq.conf has no dhcp-range and a
dhcp-leasefile as default in the config file.
Comment 4 Jima 2006-05-02 12:49:42 EDT
The problem was found to be the init script from upstream.  I've patched around
the issue and am releasing dnsmasq-2.30-4.2 to resolve this bug.

Note You need to log in before you can comment on or make changes to this bug.