Bug 190392 - cman init scripts seem to always fail when stopping
Summary: cman init scripts seem to always fail when stopping
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cman   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Abhijith Das
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-01 21:32 UTC by Corey Marthaler
Modified: 2009-04-16 19:55 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0556
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:32:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for bz (703 bytes, patch)
2006-05-02 19:28 UTC, Abhijith Das
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0556 normal SHIPPED_LIVE cman bug fix update 2006-08-10 04:00:00 UTC

Description Corey Marthaler 2006-05-01 21:32:53 UTC
Description of problem:
I've been seeing this a lot lately and it's annoying me. :)

I'll try and debug this a bit more later but here's what I've been seeing:

[root@taft-01 ~]# cat /proc/cluster/services
Service          Name                              GID LID State     Code
[root@taft-01 ~]# service cman stop
Stopping cman:                                             [FAILED]
[root@taft-01 ~]# cat /proc/cluster/nodes
Node  Votes Exp Sts  Name

from syslog:
May  1 10:30:42 taft-01 kernel: CMAN: we are leaving the cluster.
May  1 10:30:42 taft-01 ccsd[8725]: Cluster manager shutdown.  Attemping to
reconnect...
May  1 10:30:45 taft-01 cman: failed to stop cman failed

Version-Release number of selected component (if applicable):
[root@taft-01 ~]# rpm -q cman
cman-1.0.4-0

How reproducible:
almost every time

Comment 1 Christine Caulfield 2006-05-02 07:04:06 UTC
Needs passing to whever manages the init scripts. All the subsystems need to be
shut down. This includes ccsd which polls cman to see if it is active.

Comment 2 Corey Marthaler 2006-05-02 14:55:44 UTC
First, when did that change? Ccsd must be started before cman can be started and
we've always (since the begining of rhel4) stopped cman before stopping ccsd and
it worked just fine.

Second, stopping ccsd first still doen't help:
[root@taft-02 ~]# service ccsd stop
Stopping ccsd:                                             [  OK  ]
[root@taft-02 ~]# service cman stop
Stopping cman:                                             [FAILED]

In both cases (before and after ccsd is stopped), a leave by hand shows that the
stop did infact work:
[root@taft-02 ~]# cman_tool leave
cman_tool: Error leaving cluster: Cluster software not started
 

Comment 4 Abhijith Das 2006-05-02 19:28:53 UTC
Created attachment 128512 [details]
fix for bz

The cman init script ties the success of 'service cman stop' to successfully
completing a 'modprobe -r cman'. The 'modprobe -r' doesn't always succeed
because other modules (gfs, lock_dlm) may still be using it. This patch ties
the success of 'service cman stop' to 'cman_tool leave' which makes more sense
to me. Let me know if this works for you and I'll commit the patch.

Comment 5 Corey Marthaler 2006-05-08 21:46:57 UTC
Having the success tied to cluster membership removal does make more sense. The
patch works for me. 



Comment 6 Abhijith Das 2006-05-08 22:32:09 UTC
Checked in fix to RHEL4, HEAD and STABLE.

Comment 7 Corey Marthaler 2006-08-04 16:09:28 UTC
fix verified.

Comment 9 Red Hat Bugzilla 2006-08-10 21:32:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0556.html



Note You need to log in before you can comment on or make changes to this bug.