Bug 190396 - Review Request: netpanzer - An Online Multiplayer Tactical Warfare Game
Review Request: netpanzer - An Online Multiplayer Tactical Warfare Game
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Package Reviews List
:
Depends On: 190397
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-05-01 17:55 EDT by Hugo Cisneiros
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 16:37:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
petersen: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Hugo Cisneiros 2006-05-01 17:55:09 EDT
Spec URL: http://www.devin.com.br/eitch/rpm/fedora/SPECS/netpanzer.spec
SRPM URL: http://www.devin.com.br/eitch/rpm/fedora/5/SRPMS/netpanzer-0.8-1.src.rpm
Description: 

netPanzer is an online multiplayer tactical warfare game designed for FAST
ACTION combat. Gameplay concentrates on the core -- no resource management is
needed. The game is based on quick tactical action and unit management in
real-time. Battles progress quickly and constantly as destroyed players respawn
with a set of new units. Players can join or leave multiplayer games at any
time.

This is my new package and I need a sponsor, please :)
Comment 1 Andreas Thienemann 2006-05-01 21:32:23 EDT
Blockers:
netpanzer non-standard-group Games and Entertainment
Please also include the COPYING file as %doc, as required by the packaging
guidelines.

Suggestions:
I'd suggest changing the Requires: netpanzer-data to netpanzer-data = %{version}
That way, you will not have to update the -data file, when you rebuild the
executable, thus saving bandwidth.
Right now, it is depending by default on netpanzer-data = %{version}-%{release}.

The netpanzer.xpm file is probably unnecessary, especially as the .png file is
referring to the .png file.

Good:
 * proper naming
 * spec file name matches %{name}
 * package meets packaging guidelines
 X License is GPL, License meets packaged COPYING
 * Spec file written in American English
 * Spec file is understandable
 * Package succesfully builds in mock on devel x86_64 and FC-5 x86
 * No locales/shared libraries to worry about
 * No static/libtool files
 * Package not relocatable
 * Package owns all directories it creates
 * No duplicate files
 * Proper file permissions, proper %defattr(...) in spec file
 * Package contains code
 * No need for separate doc package
 * %doc files not needed for runtime
 * No header/other devel package files to worry about
 * Desktop File included and conforming to the desktop file packaging standard
Comment 2 Hugo Cisneiros 2006-05-01 22:56:36 EDT
Updated package:

Spec URL: http://www.devin.com.br/eitch/rpm/fedora/SPECS/netpanzer.spec
SRPM URL: http://www.devin.com.br/eitch/rpm/fedora/5/SRPMS/netpanzer-0.8-2.src.rpm

Changes: 

- Changed Package's RPM Group
- Fixed Changelog entries to specify versions
- Stripped '\r' EOL from RELNOTES file
- Added COPYING file
Comment 3 Andreas Thienemann 2006-05-01 23:06:13 EDT
Thanks for updating the package with my suggestions as well as the other
suggestions on IRC.
Gonna take a look at the package tomorrow though.
Comment 4 Andreas Thienemann 2006-05-03 23:38:21 EDT
Looking good. The License is included, The Group is fixed and rpmlint is clean.

APROVED.

However, you'll still need someone to sponsor your account. I can't do it. Sorry.
Comment 5 Hans de Goede 2006-05-04 10:32:46 EDT
I can sponsor and you seem worthy of sponsering concedering your quick and
correct reactions to this review and your other opensource and Fedora
(translation / writing) work.

Dropping this back to FE-REVIEW and assigning to me. I'll do a quick Re-review
just to make sure.

Comment 6 Hans de Goede 2006-05-04 11:11:08 EDT
Looking good, the icon installation however is not according to the
freedesktop.org standard.

Please mv netpanzer.png to:
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
at the end of %install and update %files accordingly.

You should then also add the following scripts to update the icon cache:
%post
touch --no-create %{_datadir}/icons/hicolor || : 
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi

%postun
touch --no-create %{_datadir}/icons/hicolor || :
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi

These script are described in:
http://fedoraproject.org/wiki/ScriptletSnippets#head-fc74f078205565f961f6d836b77c3428619c689d
Comment 7 Hugo Cisneiros 2006-05-04 14:12:16 EDT
Updated package:

Spec URL: http://www.devin.com.br/eitch/rpm/fedora/SPECS/netpanzer.spec
SRPM URL: http://www.devin.com.br/eitch/rpm/fedora/5/SRPMS/netpanzer-0.8-3.src.rpm

Changes: 

- Changed netpanzer.png to comply with freedesktop.org standards.
- Added scripts to update the icon cache after installing

Notes:

Thanks for the support Hans de Goede. I updated the packages with your notes
from Comment #6. I now know about the freedesktop standard :-) If you have any
notes, just say and I'll update it.
Comment 8 Hans de Goede 2006-05-04 15:58:06 EDT
Looking good -> Approved!

Go create yourself an account as described here:
http://fedoraproject.org/wiki/Extras/Contributors#head-a89c07b5b8abe7748b6b39f0f89768d595234907

Follow all the steps there, don't forget signing the CLA! (or other steps) once
thats done I'll get a mail that you're awaiting sponsorship and I'll sponsor you.

While waiting for me sponsoring you you can install the client-side plague
(thats the FE buildsystem) tools and setup your CVS environment variables. These
are the next steps as described on:
http://fedoraproject.org/wiki/Extras/Contributors

After that import your package, tag it and request your first build :)
Don't be alarmed if the build fails with some missing gcc deps, rawhide and thus
the devel tree (where are initial imports are done) is broken atm.

Once your build has succeeded don't forget to close this bug with a resolution
of nextrelease.
Comment 9 Hugo Cisneiros 2006-05-04 16:24:57 EDT
Hi Hans,

I already have an account in Fedora Accounts System. My username is 'eitch' and
I joined the 'cvsextras' group. Thanks for the support :)
Comment 10 Hans de Goede 2006-05-04 16:45:48 EDT
I've just sponsored you, you should have CVS access now, but don't know how long
it takes for the system to pick this up.
Comment 11 Hugo Cisneiros 2006-05-05 16:37:15 EDT
This package is now built for FC-4 and FC-5. Closing bug. Thanks for all the
support on my first package guys :)
Comment 12 Hans de Goede 2006-05-05 16:40:39 EDT
Don't forget to build it for devel once building there is possible again and
concider adding it to comps/comps-fe5.xml.in (cvs co comps) to make it show up
in pirut.
Comment 13 Jon Ciesla 2007-02-28 08:51:04 EST
Change owner to limb@jcomserv.net (orphaned)
Comment 14 Jon Ciesla 2007-03-01 14:41:35 EST
Add lxtnow@gmail.com as co-maintainer.

Note You need to log in before you can comment on or make changes to this bug.