Bug 190407 - NetworkManager receives SIGABRT after connecting to network
NetworkManager receives SIGABRT after connecting to network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 20:24 EDT by Kenny Root
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.6.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 16:00:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from /var/log/messages (14.72 KB, text/plain)
2006-05-01 20:24 EDT, Kenny Root
no flags Details

  None (edit)
Description Kenny Root 2006-05-01 20:24:18 EDT
Description of problem:

After connecting to my network using EAP-TTLS with CCMP encryption,
NetworkManager receives SIGABRT and prints out a traceback (see attached file).

lspci:
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
(rev 01)
02:06.0 CardBus bridge: O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller
02:06.1 CardBus bridge: O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller
02:06.2 System peripheral: O2 Micro, Inc. OZ711Mx 4-in-1 MemoryCardBus Accelerator
02:06.3 CardBus bridge: O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller
02:0d.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
02:0e.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M_2 Gigabit
Ethernet (rev 03)

lsmod:
Module                  Size  Used by
snd_rtctimer            3405  0
radeon                 97377  0
drm                    63701  1 radeon
ppdev                   8645  0
autofs4                19013  1
hidp                   15937  2
rfcomm                 34517  0
l2cap                  23617  10 hidp,rfcomm
sunrpc                136573  1
ndiswrapper           146236  0
video                  14917  0
button                  6609  0
battery                 9285  0
ac                      4933  0
ipv6                  225569  16
lp                     12297  0
parport_pc             25445  1
parport                34313  3 ppdev,lp,parport_pc
floppy                 57733  0
hci_usb                15957  2
bluetooth              44069  8 hidp,rfcomm,l2cap,hci_usb
nvram                   8393  0
ohci1394               31749  0
ieee1394              288665  1 ohci1394
ehci_hcd               29005  0
uhci_hcd               28881  0
joydev                  9473  0
snd_intel8x0m          16077  0
tg3                    90309  0
snd_intel8x0           30301  1
snd_ac97_codec         83937  2 snd_intel8x0m,snd_intel8x0
snd_ac97_bus            2497  1 snd_ac97_codec
snd_seq_dummy           3781  0
snd_seq_oss            28993  0
snd_seq_midi_event      7105  1 snd_seq_oss
snd_seq                47153  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          8909  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45009  0
snd_mixer_oss          16449  1 snd_pcm_oss
snd_pcm                76869  4
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              22597  3 snd_rtctimer,snd_seq,snd_pcm
i2c_i801                8397  0
snd                    50501  12
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
i2c_core               20673  1 i2c_i801
soundcore               9377  1 snd
snd_page_alloc         10441  3 snd_intel8x0m,snd_intel8x0,snd_pcm
dm_snapshot            15981  0
dm_zero                 2113  0
dm_mirror              19729  0
dm_mod                 50137  6 dm_snapshot,dm_zero,dm_mirror
ext3                  116169  2
jbd                    52693  1 ext3

iwlist wlan0 scanning:
wlan0     Scan completed :
          Cell 01 - Address: 00:0D:54:C4:BC:97
                    ESSID:"rootfastg"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:0/100  Signal level:-59 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                   
Extra:wpa_ie=dd180050f20101000050f20401000050f20401000050f2010000
          Cell 02 - Address: 00:0D:54:C4:BC:98
                    ESSID:"rootprint"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:0/100  Signal level:-60 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                   
Extra:wpa_ie=dd180050f20101000050f20401000050f20401000050f2020000
          Cell 03 - Address: 00:14:6C:3B:1C:C6
                    ESSID:"7410"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:0/100  Signal level:-80 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 04 - Address: 00:11:50:1A:25:DB
                    ESSID:"rootman"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.412 GHz (Channel 1)
                    Quality:0/100  Signal level:-60 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 05 - Address: 00:0D:54:C4:BC:95
                    ESSID:"rootfasta"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:5.25 GHz
                    Quality:0/100  Signal level:-73 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                   
Extra:wpa_ie=dd180050f20101000050f20401000050f20401000050f2010000
          Cell 06 - Address: 00:11:50:29:4C:0C
                    ESSID:"7410"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437 GHz (Channel 6)
                    Quality:0/100  Signal level:-63 dBm  Noise level:-256 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0



Version-Release number of selected component (if applicable):
0.6.0-3

How reproducible:
Every time the connection is complete, this happens.

Steps to Reproduce:
1. Start NetworkManager
2. Associate with network using EAP-TTLS and ndiswrapper as the driver
3. Look at /var/log/messages after NetworkManager goes away
  
Actual results:
NetworkManager stops after receiving SIGABRT

Expected results:
NetworkManager should continue functioning and monitoring network interfaces.

Additional info:
Comment 1 Kenny Root 2006-05-01 20:24:18 EDT
Created attachment 128462 [details]
Backtrace from /var/log/messages
Comment 2 Kenny Root 2006-05-02 01:19:55 EDT
I ran NetworkManager from the command line and got this extra line:

3190: assertion failed "vp->str != NULL" file "dbus-marshal-basic.c" line 888
function _dbus_marshal_write_basic
Comment 3 Kenny Root 2006-05-03 15:53:34 EDT
Looks like this happens when any of the fields in the form that pops up are
blank. Since I'm using EAP-TTLS and EAP-PEAP I didn't bother to fill out the
fields that correspond to private_key_file, private_key_passwd,
client_cert_file, or ca_cert_file.

When those variables are serialized in nmu_security_serialize_wpa_eap
(libnm-util/dbus-helpers.c:284) using the chain dbus_message_iter_append_basic
-> _dbus_type_writer_write_basic -> _dbus_type_writer_write_basic_no_typecode ->
_dbus_marshal_write_basic, dbus throws an exception because all of them are
equal to NULL which is checked in _dbus_marshal_write_basic
(dbus-marshal-basic.c:888).
Comment 4 Kenny Root 2007-10-31 16:00:10 EDT
This bug was fixed in 0.6.4

Note You need to log in before you can comment on or make changes to this bug.