Bug 1904227 - Docker repo sync probelms with 6.7.5 due to python-nectar is not upgraded properly from 6.6 -> 6.7
Summary: Docker repo sync probelms with 6.7.5 due to python-nectar is not upgraded pro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 6.8.2
Assignee: Evgeni Golov
QA Contact: Lai
URL:
Whiteboard:
: 1893561 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-03 20:45 UTC by James Jeffers
Modified: 2021-04-20 12:59 UTC (History)
8 users (show)

Fixed In Version: python-nectar-1.6.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1893561
Environment:
Last Closed: 2020-12-15 13:15:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 5847451 0 None None None 2021-04-20 12:59:16 UTC
Red Hat Product Errata RHBA-2020:5467 0 None None None 2020-12-15 13:15:43 UTC

Comment 1 Lai 2020-12-08 18:39:51 UTC
Steps to Test:
 
1. Create the custom product with custom docker repo

Basic Information

Name
    docker
Label
    docker
Description
Backend Identifier
    9e5eacfa-007f-4047-967f-d5769998ebcd
Type
    docker

Sync Settings

Registry URL
    https://registry.redhat.io
Upstream Repository Name
    amq7/amq-streams-bridge-rhel7
Verify SSL
    Yes
Upstream Authorization
    ***** / ********
HTTP Proxy
    Global Default (None)
Publish via HTTPS
    Yes
Publish via HTTP
    Yes
Published At
    <sat server name>
SSL CA Cert
SSL Client Cert
SSL Client Key
Limit Sync Tags

3. sync 

Expected:
Sync successfully

Actual:
Sync successfully

Verified that nectar is python-nectar python-nectar-1.6.4-1.el7sat.noarch
Verified that /var/log/messages shows no error

Verified on 6.8.2 snap 3

Comment 6 errata-xmlrpc 2020-12-15 13:15:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Satellite 6.8.2 Async Bug Fix Update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5467

Comment 7 Brad Buckingham 2021-04-20 12:59:16 UTC
*** Bug 1893561 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.