Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Rsync is used to synchronize the content inside a container. Since I tried to upgrade the parent image from fedora 31 to fedora 33, I'm facing a permission problem Steps to Reproduce: 1. Build 2 container images based on fedora 31 and fedora 33 Dockerfile: --- ARG VERSION FROM fedora:$VERSION RUN dnf update -y && dnf install -y \ rsync-daemon \ rsync \ && dnf clean all RUN mkdir -p /test-rsync COPY rsyncd.conf /etc/rsyncd.conf --- rsyncd.conf: --- gid = 0 uid = 0 log file = /dev/stdout reverse lookup = no [rsync] hosts allow = * read only = false path = /test-rsync comment = input sources --- Build for fedora 31: V=31 docker build --tag rsync-fedora-$V --build-arg "VERSION=$V" . Build for fedora 33: V=33 docker build --tag rsync-fedora-$V --build-arg "VERSION=$V" . 2. Rsync in the container: For fedora 31: 4 docker run -td -p 8080:873 --name rsync-fedora-31 rsync-fedora-31 /usr/bin/rsync --no-detach --daemon --verbose rsync a dir: $ rsync -val $(pwd) rsync://root.0.1:8080/rsync sending incremental file list test/ test/aaa For fedora 33: $ docker run -td -p 8081:873 --name rsync-fedora-33 rsync-fedora-33 /usr/bin/rsync --no-detach --daemon --verbose rsync dir: $ rsync -val $(pwd) rsync://root.0.1:8081/rsync sending incremental file list rsync: [generator] failed to set permissions on "/test" (in rsync): Operation not supported (95) test/ test/aaa rsync: [receiver] failed to set permissions on "/test/.aaa.qCW8VK" (in rsync): Operation not supported (95) sent 133 bytes received 252 bytes 770.00 bytes/sec total size is 0 speedup is 0.00 rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1330) [sender=3.2.3] sent 133 bytes received 39 bytes 344.00 bytes/sec total size is 0 speedup is 0.00 Actual results: Cannot rsync because of "Operation not supported" Expected results: The same as for fedora 31
I guess is related to https://bugzilla.redhat.com/show_bug.cgi?id=1894485
Hi Alice, thanks for the report, that seems to be indeed the same as bug #1894485, can you try to use rsync and rsync-daemon from this scratch build in the F33 container? I added the fix from upstream that should resolve the lchmod issue: https://koji.fedoraproject.org/koji/taskinfo?taskID=57025188 ? Just choose the correct arch and install rsync and rsync-daemon rpms. If that fixes the issue(I am positive it will) I will mark this bug as duplicate of the original one. Thanks, Michal
hi Michal, could you please point me where I can find the right version of the glibc rpm needed by rsync-3.2.3-4: libc.so.6(GLIBC_2.33)(64bit) Many thanks, Alice
Hi, sorry Alice, the libc.so.6(GLIBC_2.33)(64bit) is in f34, if you are trying this with f33, please try this build of rsync instead: https://koji.fedoraproject.org/koji/taskinfo?taskID=57038232. The highest version of glibc lib is libc.so.6(GLIBC_2.32)(64bit) in f33. Sorry for the wrong branch, hopefully the f33 build should pull correct dependencies. Regards, Michal
Hi Michal, no problem! I can confirm that with the RPMs available at: https://koji.fedoraproject.org/koji/taskinfo?taskID=57038232 the issue is solved! Many thanks! Alice
Thanks a lot Alice, I have submitted the fix for f33 and Rawhide. I will close this bug as duplicate. The status of the update can now be observed in the original bug. Thanks again. Michal *** This bug has been marked as a duplicate of bug 1894485 ***