Bug 1904354 - python-xarray: FTBFS in Fedora rawhide
Summary: python-xarray: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-xarray
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-04 07:55 UTC by Tomáš Hrnčiar
Modified: 2020-12-21 01:32 UTC (History)
2 users (show)

Fixed In Version: python-xarray-0.16.2-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-21 01:32:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-12-04 07:55:50 UTC
Description of problem:
Package python-xarray fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.16.1-1.fc34

Steps to Reproduce:
koji build --scratch f34 python-xarray-0.16.1-1.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-xarray

==================================== ERRORS ====================================
___________ ERROR at teardown of TestAxesKwargs.test_ylim_kwarg[da0] ___________
[gw1] linux -- Python 3.10.0 /usr/bin/python3

    @pytest.fixture(scope="module", autouse=True)
    def test_all_figures_closed():
        """meta-test to ensure all figures are closed at the end of a test
    
        Notes:  Scope is kept to module (only invoke this function once per test
        module) else tests cannot be run in parallel (locally). Disadvantage: only
        catches one open figure per run. May still give a false positive if tests
        are run in parallel.
        """
        yield None
    
        open_figs = len(plt.get_fignums())
        if open_figs:
>           raise RuntimeError(
                f"tests did not close all figures ({open_figs} figures open)"
            )
E           RuntimeError: tests did not close all figures (1 figures open)

/builddir/build/BUILDROOT/python-xarray-0.16.1-1.fc34.x86_64/usr/lib/python3.10/site-packages/xarray/tests/test_plot.py:71: RuntimeError
=================================== FAILURES ===================================
__________ test_decode_non_standard_calendar_single_element[360_day] ___________
[gw0] linux -- Python 3.10.0 /usr/bin/python3

calendar = '360_day'

    @requires_cftime
    @pytest.mark.parametrize("calendar", ["360_day", "all_leap", "366_day"])
    def test_decode_non_standard_calendar_single_element(calendar):
        import cftime
    
        units = "days since 0001-01-01"
    
>       dt = cftime.datetime(2001, 2, 29)

/builddir/build/BUILDROOT/python-xarray-0.16.1-1.fc34.x86_64/usr/lib/python3.10/site-packages/xarray/tests/test_coding_times.py:400: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
cftime/_cftime.pyx:948: in cftime._cftime.datetime.__init__
    ???
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

>   ???
E   ValueError: invalid day number provided in cftime.datetime(2001, 2, 29, 0, 0, 0, 0, calendar='gregorian')

cftime/_cftime.pyx:1492: ValueError
__________ test_decode_non_standard_calendar_single_element[all_leap] __________
[gw0] linux -- Python 3.10.0 /usr/bin/python3

calendar = 'all_leap'

    @requires_cftime
    @pytest.mark.parametrize("calendar", ["360_day", "all_leap", "366_day"])
    def test_decode_non_standard_calendar_single_element(calendar):
        import cftime
    
        units = "days since 0001-01-01"
    
>       dt = cftime.datetime(2001, 2, 29)

/builddir/build/BUILDROOT/python-xarray-0.16.1-1.fc34.x86_64/usr/lib/python3.10/site-packages/xarray/tests/test_coding_times.py:400: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
cftime/_cftime.pyx:948: in cftime._cftime.datetime.__init__
    ???
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

>   ???
E   ValueError: invalid day number provided in cftime.datetime(2001, 2, 29, 0, 0, 0, 0, calendar='gregorian')

cftime/_cftime.pyx:1492: ValueError
__________ test_decode_non_standard_calendar_single_element[366_day] ___________
[gw0] linux -- Python 3.10.0 /usr/bin/python3

calendar = '366_day'

    @requires_cftime
    @pytest.mark.parametrize("calendar", ["360_day", "all_leap", "366_day"])
    def test_decode_non_standard_calendar_single_element(calendar):
        import cftime
    
        units = "days since 0001-01-01"
    
>       dt = cftime.datetime(2001, 2, 29)

/builddir/build/BUILDROOT/python-xarray-0.16.1-1.fc34.x86_64/usr/lib/python3.10/site-packages/xarray/tests/test_coding_times.py:400: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
cftime/_cftime.pyx:948: in cftime._cftime.datetime.__init__
    ???
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

>   ???
E   ValueError: invalid day number provided in cftime.datetime(2001, 2, 29, 0, 0, 0, 0, calendar='gregorian')

cftime/_cftime.pyx:1492: ValueError

Comment 1 Fedora Release Engineering 2020-12-06 04:22:57 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-01-29).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 2 Fedora Update System 2020-12-13 00:14:18 UTC
FEDORA-2020-e2e8ab9fd8 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e2e8ab9fd8

Comment 3 Fedora Update System 2020-12-13 03:00:25 UTC
FEDORA-2020-e2e8ab9fd8 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e2e8ab9fd8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e2e8ab9fd8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-12-21 01:32:53 UTC
FEDORA-2020-e2e8ab9fd8 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.