Bug 190449 - REGRESSION: Serial console hang on HP Integrity servers
REGRESSION: Serial console hang on HP Integrity servers
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
ia64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-02 11:03 EDT by Doug Chapman
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 15:43:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-05-02 11:03:29 EDT
Description of problem:
The remote serial console using the MP (management processor) interface on many
of the HP Integrity servers hangs on recent RHEL4 kernels.  This was introduced
by the patch for BZ 166591 and I updated that BZ with this info.  Since this has
been in for about 2 weeks now I am filing a new BZ to make it clear that this is
a very critical regression.

Version-Release number of selected component (if applicable):
Started in 2.6.9-34.21

How reproducible:
On certain systems I hit this 100% of the time.  All of the low end systems hit
this at one time or another.  The rx2600 can hit it 100% of the time when I
bring up any network device via ifup (appears that the messages it writes to the
console trigger it).


Steps to Reproduce:
Easiest and most reliable way is to:
1. Connect to the management processor console via telnet
2. configure network devices to not enable on boot
3. Install 2.6.9-34.22 or later
4. after bootup log in via console
5. ifup eth0 - note that it hangs until you hit a key

It also often hangs when it starts init or sometimes at other random points
during bootup.


  
Actual results:


Expected results:


Additional info:
Comment 1 James Laska 2006-05-02 12:45:47 EDT
Doug: I hate to ask ... but it's a good data point ... Has the firmware changed
on the MP at all recently?
Comment 2 Doug Chapman 2006-05-02 13:09:17 EDT
James,

That is a good question but no, I have not changed firmware on the systems in my
own test ring in quite some time.  Also, I can make my systems work OK when I
removed the serial patch for BZ 166591.
Comment 3 Jason Baron 2006-05-03 15:43:30 EDT
ok, this is fixed by reverting the patch for 166591

Note You need to log in before you can comment on or make changes to this bug.