Bug 190458 - foo.i386 vs foo.x86_64
Summary: foo.i386 vs foo.x86_64
Status: CLOSED DUPLICATE of bug 177736
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 4.0
Hardware: x86_64 Linux
medium
low
Target Milestone: ---
: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-02 15:48 UTC by David Johnston
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 14:12:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Johnston 2006-05-02 15:48:01 UTC
Request for enhancement

Description of problem:
On x86_64 platforms, a single package can get installed twice (once as 32-bit,
once as 64 bit).  This works fine (and is sometimes necessary) but can cause
problems when the package is upgraded.  The most common symptom is an error like
this:
"Transaction Check Error:   file /usr/share/man/man1/asn1parse.1ssl.gz from 
install of openssl-0.9.7a-43.8 conflicts with file from package 
openssl-0.9.7a-43.8"

Note that openssl-0.9.7a-43.8 appears to be conflicting with itself (the version
numbers are the same).

Suggested fix:
Replace
  %_query_all_fmt %%{name}-%%{version}-%%{release}
with
  %_query_all_fmt %%{name}-%%{version}-%%{release}.%%{arch}
in
  /usr/lib/rpm/macros

If this is done, the operator will be able to see the problem clearly:
openssl-0.9.7a-43.8.i386
openssl-0.9.7a-43.8.x86_64

A search through Bugzilla turned up several WONTFIX bugs from 2003 that relate
to this quirk of RPM on 64-bit systems.  In 2003, 64-bit systems where only used
by experienced operators with large budgets; this is no longer the case.

This fix won't solve the underlying problem, but it is a start.

Comment 1 Jeff Johnson 2006-05-02 22:40:02 UTC
FWIW, this is fixed in rpm-4.4.2 and later.

And the workaround is just to configure your own system by putting
    %_query_all_fmt %%{name}-%%{version}-%%{release}.%%{arch}
in /etc/rpm/macros. 

Comment 2 Paul Nasrat 2006-06-30 14:12:28 UTC

*** This bug has been marked as a duplicate of 177736 ***


Note You need to log in before you can comment on or make changes to this bug.