Bug 1904650 - /usr/bin/time bash -c 'echo test >&2' failed since STDERR is closed by the time utilit
Summary: /usr/bin/time bash -c 'echo test >&2' failed since STDERR is closed by the ti...
Keywords:
Status: CLOSED DUPLICATE of bug 1898138
Alias: None
Product: Fedora
Classification: Fedora
Component: time
Version: 33
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-05 09:03 UTC by Leonid Yuriev
Modified: 2020-12-14 09:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-14 09:16:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Leonid Yuriev 2020-12-05 09:03:45 UTC
Description of problem:
The command "/usr/bin/time bash -c 'echo test >&2'" failed since STDERR is closed by the time utility.

Version-Release number of selected component (if applicable):
Name         : time
Version      : 1.9
Release      : 11.fc33
Architecture : x86_64
Size         : 87 k
Source       : time-1.9-11.fc33.src.rpm
Repository   : @System
From repo    : updates
Summary      : A GNU utility for monitoring a program's use of system resources
URL          : http://www.gnu.org/software/time/
License      : GPLv3+ and GFDL
Description  : The GNU time utility runs another program, collects information about
             : the resources used by that program while it is running, and displays
             : the results.


How reproducible:
$ /usr/bin/time bash -c 'echo test >&2'


Actual results:
Command exited with non-zero status 1
0.00user 0.00system 0:00.00elapsed 100%CPU (0avgtext+0avgdata 3504maxresident)k
0inputs+0outputs (0major+182minor)pagefaults 0swaps

Expected results:
test
0.00user 0.00system 0:00.00elapsed 100%CPU (0avgtext+0avgdata 3312maxresident)k
0inputs+0outputs (0major+141minor)pagefaults 0swaps


Additional info:
https://github.com/erthink/libmdbx/issues/144

Comment 1 Leonid Yuriev 2020-12-05 09:11:06 UTC
Seems this is duplicate of the https://bugzilla.redhat.com/show_bug.cgi?id=1898138

But in my case this leads to a database corruption (https://github.com/erthink/libmdbx/issues/144).

Comment 2 Leonid Yuriev 2020-12-05 09:18:16 UTC
Another minor problem is the 'time' component at bugzilla.redhat.com mismatch to the `time` package.

Comment 3 Petr Pisar 2020-12-14 09:16:21 UTC

*** This bug has been marked as a duplicate of bug 1898138 ***


Note You need to log in before you can comment on or make changes to this bug.