Bug 190509 - Add-to-panel -> Hardware-sensors-monitor crashes immediately
Add-to-panel -> Hardware-sensors-monitor crashes immediately
Product: Fedora
Classification: Fedora
Component: gnome-applet-sensors (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-05-02 22:23 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.8.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-18 16:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Ellson 2006-05-02 22:23:53 EDT
Description of problem:
"Add-to-panel -> Hardware-sensors-monitor -> Add" crashes immediately at startup
on X86_64

This worked OK until about a month ago.  The same lm_sensors version works OK in
FC5 on similar hardware.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Add-to-panel -> Hardware-sensors-monitor -> Add
Actual results:
     The Application "sensors-applet" has quit unexpectedly.

    You can inform the developers of what happened to help them fix it.  Or you
 can restart the application right now.

Expected results:
I'd really like to monitor my cpu temp.....

Additional info:
Comment 1 Phil Knirsch 2006-05-12 08:17:49 EDT
That sounds more like a GUI applet problem though...

Do you know which actual application gets added to the panel when you try this?

Read ya, Phil
Comment 2 John Ellson 2006-05-12 08:38:00 EDT
Its hard to tell, isn't it.

I think its /usr/libexec/sensors-applet
but a little more visibility into what the menu does would be nice!

I've no idea how to find out what command line is used.

I tried running /usr/libexec/sensors-applet with no args
but it just sits there for abou 30sec
(on a poll() according to strace) and then exits.
Comment 3 John Ellson 2006-05-12 09:20:38 EDT
/usr/libexec/sensors-applet is from:
Comment 4 Hans de Goede 2007-07-16 08:42:11 EDT

Short introduction, I'm a Fedora contributer and since I'm involved in
lm_sensors upstream, I've also become a co-maintainer of lm_sensors in Fedora.

I concure with Phil that this is a gnome-sensors-applet bug, not a lm_sensors
bug. I've seen the same behaviour with gnome-sensors-applet on my system.

gnome-sensors-applet used to be maintained by Aaron Kurtz, who unfortunately no
longer is a Fedora Contributer, which has caused the version of
gnome-applet-sensors in Fedora to become somewhat stale.

As of today I've taken over gnome-sensors-applet from him.

As said I had the same problem and for my updating to the latest upstream
version of gnome-applet-sensors has fixed this. I've build a new Fedora package
of this version: gnome-applet-sensors-1.8.1-1.fc7

This package should become available in the updates-testing repository soon,
when its gets pushed there the update system will add a comment to this bug that
it has become available.

To use / test it once available there do:
yum update gnome-applet-sensors --enablerepo=updates-testing
Comment 5 Fedora Update System 2007-07-16 12:54:51 EDT
gnome-applet-sensors-1.8.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-07-18 16:58:12 EDT
gnome-applet-sensors-1.8.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.