Bug 190515 - [oowriter] [hi] sequence checking rejecting user input
[oowriter] [hi] sequence checking rejecting user input
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n, Reopened
Depends On:
Blocks: Indic 217269
  Show dependency treegraph
 
Reported: 2006-05-03 03:07 EDT by A S Alam
Modified: 2013-07-02 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.4-5.5.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 03:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (20.13 KB, image/png)
2006-05-03 04:39 EDT, Caolan McNamara
no flags Details

  None (edit)
Description A S Alam 2006-05-03 03:07:11 EDT
Description of problem:
When try to put 2nd character after 1st character WithOut giving space, Second 
character is not appearing on screen, (not able to commit)


Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.2-5.12.3
openoffice.org-core-2.0.2-5.12.3

How reproducible:
Everytime

Steps to Reproduce:
1. open oowriter ("LANG=hi_IN.UTF-8 oowriter" can be used, but exist for en_US also)
2. Ctrl+Space (SCIM - Select Hindi-Inscript from task panel by right clicking)
3. Press M + S + K (press any other character)

Actual results:
you are able to see only first key stroke (M) 's Result, but not from others (S+K)

Expected results:
Result from all key should be available

Additional info:
1 .This is problem only specfic to oowriter, but not in ooimpress, oocalc
2. Issue is not producable to other Indic (bn,gu,pa,ta) Language
3. If you try to input other language (other than Hindi), that are fine in
hi_IN.UTF-8 oowriter
Comment 1 Caolan McNamara 2006-05-03 03:20:25 EDT
wrong bug, reopen
Comment 2 Caolan McNamara 2006-05-03 04:39:53 EDT
Created attachment 128531 [details]
screenshot

> rpm -q openoffice.org-writer
openoffice.org-writer-2.0.2-5.12.3
> rpm -q fonts-hindi
fonts-hindi-1.10-2.1
> export LANG=hi_IN.UTF-8
> oowriter

No success in reproducing yet
Comment 3 Caolan McNamara 2006-05-19 13:59:14 EDT
Works for me as in screenshot :-(
Comment 4 Jens Petersen 2006-11-26 20:06:32 EST
Should this bug be updated to fc6?
Comment 5 Jens Petersen 2006-11-27 23:35:00 EST
Actually no, this seems to work ok with FC6.
Comment 6 Jens Petersen 2006-11-28 21:34:10 EST
I can reproduce on FC6 with openoffice.org-2.0.4-5.5.3 when
openoffice.org-langpack-hi_IN is installed.
Comment 7 Caolan McNamara 2006-11-29 05:23:45 EST
ah ha!, I see our problem. i.e. tools->options->language settings->Complex Text
Layout->Sequence checking is set to "on" by default, and it's rejecting what
we're typing
Comment 8 Caolan McNamara 2006-11-29 06:24:10 EST
so lets set that to off by default, will be in next scheduled FC-6 update, we
have a seperate tracker for RHEL bug 217269

Note You need to log in before you can comment on or make changes to this bug.