Bug 1905268 - putty crash: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
Summary: putty crash: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkSc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: putty
Version: 33
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-07 22:02 UTC by Ivo Sarak
Modified: 2021-04-28 08:44 UTC (History)
6 users (show)

Fixed In Version: putty-0.74-4.fc35 putty-0.74-4.fc34 putty-0.74-4.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-16 18:08:49 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Ivo Sarak 2020-12-07 22:02:19 UTC
Description of problem:
The putty will crash due to some font related issue

Version-Release number of selected component (if applicable):
putty-0.74-2.fc33.x86_64

How reproducible:
always

Steps to Reproduce:
1. Under Fedora 33, install putty, start it and try to connect to a host

Actual results:
[ivo@l2ppar ~]$ putty

(putty:17421): Gtk-CRITICAL **: 23:56:27.368: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(putty:17421): Gtk-CRITICAL **: 23:56:27.371: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(putty:17421): Gtk-CRITICAL **: 23:56:27.374: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
PuTTY: unable to load font "server:fixed"
[ivo@l2ppar ~]$ 


Expected results:
The putty running 

Additional info:

Comment 1 Ivo Sarak 2021-01-13 21:44:18 UTC
[ivo@l2ppar ~]$ putty 192.168.0.1
PuTTY: unable to load font "server:fixed"
[ivo@l2ppar ~]$

Comment 2 Davide Cavalca 2021-01-25 01:04:40 UTC
Put up a fix for this in https://src.fedoraproject.org/rpms/putty/pull-request/3

Comment 3 Jaroslav Škarvada 2021-01-25 21:50:17 UTC
(In reply to Davide Cavalca from comment #2)
> Put up a fix for this in
> https://src.fedoraproject.org/rpms/putty/pull-request/3

Thanks for researching the problem, but to be honest for me it seems like very dirty hack.

Can we just go with the -DNOT_X_WINDOWS?

Even on X windows it seems it works correctly for me with the -DNOT_X_WINDOWS (I reported build error to upstream regarding -Werror=unused-function). But I did just very simple functional check.

Comment 4 Jaroslav Škarvada 2021-03-16 17:52:40 UTC
(In reply to Jaroslav Škarvada from comment #3)
> (In reply to Davide Cavalca from comment #2)
> > Put up a fix for this in
> > https://src.fedoraproject.org/rpms/putty/pull-request/3
> 
> Thanks for researching the problem, but to be honest for me it seems like
> very dirty hack.
> 
> Can we just go with the -DNOT_X_WINDOWS?
> 
> Even on X windows it seems it works correctly for me with the
> -DNOT_X_WINDOWS (I reported build error to upstream regarding
> -Werror=unused-function). But I did just very simple functional check.

I will try -DNOT_X_WINDOWS.

Comment 5 Fedora Update System 2021-03-16 18:08:49 UTC
FEDORA-2021-12c5da5a3f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2021-03-16 18:24:53 UTC
FEDORA-2021-cfb16bb8ff has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-cfb16bb8ff

Comment 7 Fedora Update System 2021-03-16 18:36:37 UTC
FEDORA-2021-5430e4e60c has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5430e4e60c

Comment 8 Fedora Update System 2021-03-16 23:30:40 UTC
FEDORA-2021-cfb16bb8ff has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-cfb16bb8ff`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-cfb16bb8ff

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-03-17 01:41:50 UTC
FEDORA-2021-5430e4e60c has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5430e4e60c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5430e4e60c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-03-20 00:16:58 UTC
FEDORA-2021-cfb16bb8ff has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2021-03-24 02:39:51 UTC
FEDORA-2021-5430e4e60c has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 bes1002t 2021-04-28 08:44:18 UTC
It seems this issue still persists. If I change the used font in "Fonts" from 'server:fixed' to another Font, Putty will open the console window again.
But, for most fonts the window will be still empty. The only font that worked so far is 'FreeMono'.

By the way, it would be good if putty could show an error message if there is an error that causes putty to close. Because if you do not open putty in the terminal, you will not know what happened. Even the putty session log is not written, so there is no information for common users why putty does not work anymore.


- Linux 5.11.16-200.fc33.x86_64 #1 SMP Wed Apr 21 16:08:37 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
- putty-0.74-4.fc33.x86_64


Note You need to log in before you can comment on or make changes to this bug.