Bug 190543 - kernel 2107 causes problems for nfs, ypbind
kernel 2107 causes problems for nfs, ypbind
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-05-03 09:45 EDT by Thomas J. Baker
Modified: 2015-01-04 17:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-06 20:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2006-05-03 09:45:43 EDT
Description of problem:

Just installed kernel-2.6.16-1.2107_FC5 on a x86_64 smp machine. ypbind hangs
during boot trying to find a ypserver and rpc.statd was reporting problems too.
Rebooting to kernel-2.6.16-1.2096_FC5 works fine. Maybe it's a problem with
kernel udp since I grepped these from /var/log/messages:

May  3 09:01:40 wintermute rpc.statd[2248]: unable to register (statd, 1, udp).
May  3 09:01:40 wintermute ypbind[2383]: Unable to register (YPBINDPROG,
May  3 09:19:33 wintermute rpc.statd[2256]: unable to register (statd, 1, udp).
May  3 09:19:33 wintermute ypbind[2391]: Unable to register (YPBINDPROG,

Version-Release number of selected component (if applicable):


How reproducible:

I tried two boots with the same results.

Steps to Reproduce:
1. install new kernel
2. reboot
Actual results:

boot hangs at ypbind and rpc.statd reported some problems that don't seem to be
logged completely.

Expected results:

Additional info:
Comment 1 Thomas J. Baker 2006-05-03 09:54:37 EDT
P.S. selinux is in permissive mode.
Comment 2 Peter Bieringer 2006-05-03 11:46:59 EDT
Same happen to me, NFS server is RHEL4, /home is mounted. After user login,
/home/user works fine, but executing "startx" on client, NFS suddenly dies. ls
/home on client hangs.
Comment 3 Erwin J. Prinz 2006-05-03 20:36:26 EDT
Similar issue with kernel 2.6.16-1.2107_FC5smp on dual 600MHz Xeon Dell
Precision workstation. After boot, accessing a /home directory mounted by NFS
from a server results in a hang. Shutdown/reboot hangs when autofs tries to
stop. Machine has to be power-cycled to reboot. Also, some files at /home/(user)
which are accessed by gnome startup in .gconf or .gconfd get corrupted, and have
to be deleted to be able to log back in after successfully booting with the
prior kernel.

I reproduced this 2 times, and the only change is the kernel version, with
2.6.16-1.2107_FC5smp being the "bad" one.
Comment 4 Dave Jones 2006-05-03 23:35:52 EDT
does booting with pci=nomsi make this go away?
Comment 5 Dave Jones 2006-05-04 00:12:33 EDT
Actually, that option is also broken in this kernel (sigh).

2108, available from http://people.redhat.com/davej/kernels/Fedora/FC5/
has this disabled by default. Give that a try ?
Comment 6 David Mohring 2006-05-04 01:28:49 EDT
2.6.16-1.2107_FC5smp on Intel(R) Pentium(R) 4 CPU 2.40GHz breaks NFS for me as

Our diskless LTSP clients failed because they could not mount their root FS.
Reverting back to kernel-smp-2.6.16-1.2080_FC5 on the above server solved the
Comment 7 Thomas J. Baker 2006-05-04 08:32:56 EDT
Just tried the 2108 kernel and it does not work for me. Seems to be the same
Comment 8 JM 2006-05-04 10:34:36 EDT
I have the same problem (x86_64 and i386, with and without SMP), the kernel 2096
work with 2107 ypbind for example fails.
Comment 9 Joe Christy 2006-05-04 15:13:09 EDT
I have problems with NFS, too, both with 2107 and 2108.

BUT I'm not running yp, and my problems are on the server side. Should this go
in a new bug?

FWIW, I have a pcap of the (hung) NFS conversation between the client and the
Comment 10 Joe Christy 2006-05-05 17:19:14 EDT
2111 solved my problem

Note You need to log in before you can comment on or make changes to this bug.