Bug 190573 - yumdownloader does not fetch multiple packages
yumdownloader does not fetch multiple packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 13:37 EDT by Chien-Chung Yeh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 10:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chien-Chung Yeh 2006-05-03 13:37:35 EDT
Description of problem:
yumdownloader does not fetch multiple packages, it merely fetch the first one.

Version-Release number of selected component (if applicable):
yum-2.6.0-1 ; yum-utils-0.5-1

How reproducible:
Always


Steps to Reproduce:
1. yumdownloader --resolve bison.i386 libdvdplay.i386 ibm-data-db2.i386
2.
3.
  
Actual results:
/usr/lib/python2.4/site-packages/yum/config.py:447: DeprecationWarning: 
setConfigOption() will go away in a future version of Yum.
Please set option values as attributes or using setattr().
  DeprecationWarning)
/usr/lib/python2.4/site-packages/yum/config.py:439: DeprecationWarning: 
getConfigOption() will go away in a future version of Yum.
Please access option values as attributes or using getattr().
  DeprecationWarning)
core                                                                 [1/3]
extras                                                               [2/3]
updates                                                              [3/3]
Excluding Packages in global exclude list
Finished
bison-2.1-2.FC5.i386.rpm  100% |=========================| 502 kB    00:02

Expected results:
Download all three packages.

Additional info:
All three packages not excluded by /etc/yum.conf, and no *.rpm in current 
direcory.
Comment 1 Chien-Chung Yeh 2006-05-08 10:08:43 EDT
Due to newly introduced "yum-downloadonly" packges, we do not need to fix this 
bug immediately, but it still is a bug, so just change Severity to "low".
Comment 2 Seth Vidal 2006-05-08 10:11:38 EDT
actually, if you'll look at the yum-downloader program in yum-utils 0.6 you'll
find that it handles multiple packages.

closing this bug

Note You need to log in before you can comment on or make changes to this bug.