Bug 190600 - Samba wedges boot with kernel 2.6.16-1.2107_FC5
Summary: Samba wedges boot with kernel 2.6.16-1.2107_FC5
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-03 20:15 UTC by Joe Christy
Modified: 2015-01-04 22:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-07 00:09:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from 1/4 non-samba-hanging boot (20.88 KB, text/plain)
2006-05-04 19:22 UTC, Joe Christy
no flags Details
ethereal packet capture of hanging NFS incoming mount request (7.63 KB, application/octet-stream)
2006-05-04 19:25 UTC, Joe Christy
no flags Details

Description Joe Christy 2006-05-03 20:15:03 UTC
Description of problem:


Version-Release number of selected component (if applicable):
2.6.16-1.2107_FC5 

How reproducible:
4 out of 5 times

Steps to Reproduce:
1. "upgrade" kernel to 2.6.16-1.2107_FC5 on a machine running samba
2. reboot
3.
  
Actual results:
boot process wedges hard when service smb starts

Expected results:
boot completes

Additional info:

Since there was no change to my samba configuration , I suspect that this is a
kernel issue.

I saw this behaviour 3/3 times with kernel-2.6.16-1.2107_FC5 and 1/2 times with
kernel-smp-2.6.16-1.2107_FC5, both on a hyperthreaded P4.  Since NFS was hosed
and I serve several partitions, using both NFS and samba, to my network from
this machine, I gave up at that point.

NB X was not running, so this seems unrelated to the X bugs,
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190424 or
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190575, but is possibly
related to 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190543.

Comment 1 Dave Jones 2006-05-04 03:37:20 UTC
does booting with pci=nomsi make this go away?

Comment 2 Dave Jones 2006-05-04 04:14:40 UTC
Actually, that option is also broken in this kernel (sigh).

2108, available from http://people.redhat.com/davej/kernels/Fedora/FC5/
has this disabled by default. Give that a try ?


Comment 3 Joe Christy 2006-05-04 19:21:17 UTC
With 2108 I see the same not quite every time failures: 0/1 success with the up
kernel, 1/2 success with the smp kernel.

Once again, even when samba doesn't hang the boot, NFS mount requests to the NFS
server on this machine hang.

For your edification I'm adjoining the dmesg output from the non-samba-hanging
boot and an ethereal packet capture of the hanging NFS mount request.

Comment 4 Joe Christy 2006-05-04 19:22:32 UTC
Created attachment 128623 [details]
dmesg output from 1/4 non-samba-hanging boot

Comment 5 Joe Christy 2006-05-04 19:25:57 UTC
Created attachment 128624 [details]
ethereal packet capture of hanging NFS incoming mount request

This is from the 1/4 non-samba-hanging boot with 2108

Comment 6 Joe Christy 2006-05-05 21:20:30 UTC
2111 solved my problem


Note You need to log in before you can comment on or make changes to this bug.