Bug 1906027 - libgexiv2: FTBFS in Fedora rawhide
Summary: libgexiv2: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgexiv2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-09 14:49 UTC by Tomáš Hrnčiar
Modified: 2021-02-16 20:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-16 20:08:03 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 97172 0 P1 RESOLVED [11 Regression] ICE: tree code ‘ssa_name’ is not supported in LTO streams since r11-3303-g6450f07388f9fe57 2021-02-15 16:14:35 UTC

Description Tomáš Hrnčiar 2020-12-09 14:49:35 UTC
Description of problem:
Package libgexiv2 fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.12.1-3.fc33

Steps to Reproduce:
koji build --scratch f34 libgexiv2-0.12.1-3.fc33.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/libgexiv2


Found ninja-1.10.1 at /usr/bin/ninja
+ /usr/bin/meson compile -C x86_64-redhat-linux-gnu -j 2 --verbose
ninja: Entering directory `x86_64-redhat-linux-gnu'
[1/23] /usr/bin/meson --internal exe --capture gexiv2/gexiv2-enums.h -- /usr/bin/glib-mkenums --identifier-prefix gexiv2 --symbol-prefix GExiv2 --template /builddir/build/BUILD/gexiv2-0.12.1/x86_64-redhat-linux-gnu/../gexiv2/gexiv2-enums.h.template /builddir/build/BUILD/gexiv2-0.12.1/x86_64-redhat-linux-gnu/../gexiv2/gexiv2-metadata.h /builddir/build/BUILD/gexiv2-0.12.1/x86_64-redhat-linux-gnu/../gexiv2/gexiv2-log.h
[2/23] gcc -Itest/gexiv2-regression.p -Itest -I../test -I. -I.. -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -pthread '-DSAMPLE_PATH="/builddir/build/BUILD/gexiv2-0.12.1/test/data"' -MD -MQ test/gexiv2-regression.p/gexiv2-regression.c.o -MF test/gexiv2-regression.p/gexiv2-regression.c.o.d -o test/gexiv2-regression.p/gexiv2-regression.c.o -c ../test/gexiv2-regression.c
FAILED: test/gexiv2-regression.p/gexiv2-regression.c.o 
gcc -Itest/gexiv2-regression.p -Itest -I../test -I. -I.. -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -pthread '-DSAMPLE_PATH="/builddir/build/BUILD/gexiv2-0.12.1/test/data"' -MD -MQ test/gexiv2-regression.p/gexiv2-regression.c.o -MF test/gexiv2-regression.p/gexiv2-regression.c.o.d -o test/gexiv2-regression.p/gexiv2-regression.c.o -c ../test/gexiv2-regression.c
*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_UNIT               | annobin: Generate final annotations
PLUGIN_START_UNIT                | annobin: Generate global annotations
PLUGIN_ALL_PASSES_START          | annobin: Generate per-function annotations
PLUGIN_ALL_PASSES_END            | annobin: Register per-function end symbols
during IPA pass: modref
../test/gexiv2-regression.c:314:1: internal compiler error: tree code ‘ssa_name’ is not supported in LTO streams
  314 | }
      | ^
0xedc5a5 diagnostic_impl(rich_location*, diagnostic_metadata const*, int, char const*, __va_list_tag (*) [1], diagnostic_t)
	???:0
0xeddbe5 internal_error(char const*, ...)
	???:0
0x79600a lto_output_tree_1(output_block*, tree_node*, unsigned int, bool, bool) [clone .constprop.0]
	???:0
0x799fd2 DFS::DFS(output_block*, tree_node*, bool, bool, bool)
	???:0
0x79a2a8 lto_output_tree(output_block*, tree_node*, bool, bool)
	???:0
0x795c8f write_global_stream(output_block*, lto_tree_ref_encoder*)
	???:0
0x79c409 produce_asm_for_decls()
	???:0
0x7f2923 write_lto()
	???:0
0x7f3b91 ipa_write_summaries()
	???:0
0x6929c7 symbol_table::compile() [clone .cold]
	???:0
0x12d7c48 symbol_table::finalize_compilation_unit()
	???:0
Please submit a full bug report,
with preprocessed source if appropriate.
Please include the complete backtrace with any bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
[3/23] /usr/bin/meson --internal exe --capture gexiv2/gexiv2-enums.cpp -- /usr/bin/glib-mkenums --identifier-prefix gexiv2 --symbol-prefix GExiv2 --template /builddir/build/BUILD/gexiv2-0.12.1/x86_64-redhat-linux-gnu/../gexiv2/gexiv2-enums.cpp.template /builddir/build/BUILD/gexiv2-0.12.1/x86_64-redhat-linux-gnu/../gexiv2/gexiv2-metadata.h /builddir/build/BUILD/gexiv2-0.12.1/x86_64-redhat-linux-gnu/../gexiv2/gexiv2-log.h
ninja: build stopped: subcommand failed.
Found runner: ['/usr/bin/ninja']

Comment 1 Fabio Valentini 2020-12-09 15:00:08 UTC
Looks like this is an LTO+annobin ICE triggered in GCC 11.

@law@redhat.com could you look into this please?

Comment 2 Jeff Law 2020-12-09 16:29:05 UTC
It's a known problem we're already tracking, but haven't settled on a solution.  This particular issue affects two packages in Fedora (I don't offhand recall the other package, but I know it exists from my own testing).

Martin, this is the unsharing issue with VLA arguments you were looking at last week.

Comment 3 Jeff Law 2020-12-09 18:26:32 UTC
radare2 is the other affected package.

Comment 4 Jeff Law 2020-12-09 21:28:23 UTC
And cava

Comment 5 Martin Sebor 2020-12-09 22:03:13 UTC
The bug is being tracked in https://gcc.gnu.org/bugzilla/show_bug.cgi?id=97172.

Comment 6 Fedora Release Engineering 2020-12-27 04:22:26 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-02-03).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 7 Dominik 'Rathann' Mierzejewski 2020-12-29 17:48:39 UTC
This is a gcc bug, so not much we can do until it's fixed.

Comment 8 Ben Cotton 2021-02-09 15:32:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 9 Lars Kellogg-Stedman 2021-02-15 15:38:42 UTC
*** Bug 1923417 has been marked as a duplicate of this bug. ***

Comment 10 Fabio Valentini 2021-02-16 20:08:03 UTC
Built for f34 and f35 using a fixed GCC build:

f35: https://koji.fedoraproject.org/koji/buildinfo?buildID=1710835
f34: https://koji.fedoraproject.org/koji/buildinfo?buildID=1681936


Note You need to log in before you can comment on or make changes to this bug.