Bug 1906036 - lirc fails to build with Python 3.10: TypeError: As of 3.10, the *loop* parameter was removed from Queue() since it is no longer necessary
Summary: lirc fails to build with Python 3.10: TypeError: As of 3.10, the *loop* param...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lirc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968834 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-09 15:01 UTC by Tomáš Hrnčiar
Modified: 2021-06-14 18:13 UTC (History)
7 users (show)

Fixed In Version: lirc-0.10.0-31.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-14 18:13:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-12-09 15:01:39 UTC
lirc fails to build with Python 3.10.0a3.

======================================================================
ERROR: testReceive1AsyncLines (test_client.ReceiveTests)
Receive 1000 lines using the async interface.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/lirc-0.10.0/python-pkg/tests/test_client.py", line 113, in testReceive1AsyncLines
    loop.run_until_complete(get_lines(conn, 1000))
  File "/usr/lib64/python3.10/asyncio/base_events.py", line 641, in run_until_complete
    return future.result()
  File "/builddir/build/BUILD/lirc-0.10.0/python-pkg/tests/test_client.py", line 94, in get_lines
    async with AsyncConnection(raw_conn, loop) as conn:
  File "/builddir/build/BUILD/lirc-0.10.0/python-pkg/lirc/async_client.py", line 66, in __init__
    self._queue = asyncio.Queue(loop=self._loop)
  File "/usr/lib64/python3.10/asyncio/queues.py", line 33, in __init__
    super().__init__(loop=loop)
  File "/usr/lib64/python3.10/asyncio/mixins.py", line 17, in __init__
    raise TypeError(
TypeError: As of 3.10, the *loop* parameter was removed from Queue() since it is no longer necessary

----------------------------------------------------------------------
Ran 7 tests in 0.911s

FAILED (errors=1)

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01818895-lirc/

For all our attempts to build lirc with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/lirc/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 15:32:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:12:51 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:57:49 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:17:02 UTC
*** Bug 1968834 has been marked as a duplicate of this bug. ***

Comment 5 Robert-André Mauchin 🐧 2021-06-14 18:13:16 UTC
I need this to build VLC F35 on RPMFusion.

I've fixed it with the following patch: https://src.fedoraproject.org/rpms/lirc/blob/rawhide/f/0001-Replace-the-obsolete-get_event_loop-with-get_running.patch

Bodhi update: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ad5f2990a8


Note You need to log in before you can comment on or make changes to this bug.