Bug 190608 - Kernel BUG at include/linux/list.h:168
Kernel BUG at include/linux/list.h:168
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 17:34 EDT by Michael Hamilton
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-06 20:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg from latest boot - to document current system config. (20.95 KB, application/octet-stream)
2006-05-03 17:34 EDT, Michael Hamilton
no flags Details

  None (edit)
Description Michael Hamilton 2006-05-03 17:34:52 EDT
Description of problem:
Desktop left running overnight froze in the Kernel probably during the daily
crontab run.  System has been quite stable otherwise.  It has successfully run
overnight on other occasions.

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2096_FC5

How reproducible:
No means to reproduce at this time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
May  4 04:02:22 gemini7 kernel: ----------- [cut here ] --------- [please bite
here ] ---------
May  4 04:02:22 gemini7 kernel: Kernel BUG at include/linux/list.h:168
May  4 04:02:22 gemini7 kernel: invalid opcode: 0000 [1] SMP
May  4 04:02:22 gemini7 kernel: last sysfs file:
/class/net/sit0/statistics/collisions
May  4 04:02:22 gemini7 kernel: CPU 0
May  4 04:02:22 gemini7 kernel: Modules linked in: usblp usb_storage appletalk
ipx p8023 ppdev autofs4 it87 hwmon_vid hwmon eeprom i2c_isa
 hidp rfcomm l2cap bluetooth sunrpc nls_utf8 ntfs(U) video button battery ac
ipv6 lp parport_pc parport nvram tuner bttv video_buf compat_
ioctl32 i2c_algo_bit v4l2_common btcx_risc ir_common snd_intel8x0 snd_ac97_codec
snd_ac97_bus tveeprom snd_seq_dummy nvidia(U) snd_seq_oss
 snd_seq_midi_event snd_seq snd_seq_device i2c_nforce2 snd_pcm_oss snd_mixer_oss
snd_pcm ohci_hcd i2c_core videodev sg ehci_hcd snd_timer
snd soundcore snd_page_alloc forcedeth dm_snapshot dm_zero dm_mirror dm_mod ext3
jbd sata_nv libata sd_mod scsi_mod
May  4 04:02:22 gemini7 kernel: Pid: 12281, comm: updatedb Tainted: P   M 
2.6.16-1.2096_FC5 #1
May  4 04:02:22 gemini7 kernel: RIP: 0010:[<ffffffff8017ab06>]
<ffffffff8017ab06>{cache_alloc_refill+314}
May  4 04:02:22 gemini7 kernel: RSP: 0018:ffff81002eeb9b48  EFLAGS: 00010083
May  4 04:02:22 gemini7 kernel: RAX: ffff8100262b3529 RBX: 000000000000000c RCX:
0000000000000010
May  4 04:02:22 gemini7 kernel: RDX: ffff81003f3eda40 RSI: ffff81000bc5a000 RDI:
ffff81003ecb9300
May  4 04:02:22 gemini7 kernel: RBP: ffff81000bc5a000 R08: 0000000000000060 R09:
0000000000001000
May  4 04:02:22 gemini7 kernel: R10: ffff81002eeb9ca8 R11: 000000000000000c R12:
ffff81003f3eda40


Expected results:


Additional info:
This time coincides with the daily crontab run.

This is a dual core system.  I'm using the nvidia drivers.

The system was installed on April 1 and has been stable since the install. This
morning I ran Seagate disk diagnostics and memtest-86 (1 full pass) - both pass.

I've attached a recent boot time dmesg in case that helps.

Only other hang on this kernel was when connecting a USB camera last weekend -
but nothing was logged on this previous occasion.  

Just before the bug the following was logged (probably one of the daily jobs):
May  4 04:02:14 gemini7 nmbd[2332]: [2006/05/04 04:02:14, 0]
nmbd/nmbd.c:process(596)
May  4 04:02:14 gemini7 nmbd[2332]:   Got SIGHUP dumping debug info.
May  4 04:02:14 gemini7 nmbd[2332]: [2006/05/04 04:02:14, 0]
nmbd/nmbd_workgroupdb.c:dump_workgroups(284)
May  4 04:02:14 gemini7 nmbd[2332]:   dump_workgroups()
May  4 04:02:14 gemini7 nmbd[2332]:    dump workgroup on subnet   202.36.184.90:
netmask=  255.255.255.0:
May  4 04:02:14 gemini7 nmbd[2332]:     GENTOO(1) current master browser = GEMINI7
May  4 04:02:14 gemini7 nmbd[2332]:             GEMINI7 400c9a03 (Gentoo Viking2
Samba Server)
May  4 04:02:14 gemini7 nmbd[2332]: [2006/05/04 04:02:14, 0]
nmbd/nmbd_workgroupdb.c:dump_workgroups(284)
May  4 04:02:14 gemini7 nmbd[2332]:   dump_workgroups()
May  4 04:02:14 gemini7 nmbd[2332]:    dump workgroup on subnet  UNICAST_SUBNET:
netmask=  202.36.184.90:
May  4 04:02:14 gemini7 nmbd[2332]:     GENTOO(1) current master browser = UNKNOWN
May  4 04:02:14 gemini7 nmbd[2332]:             GEMINI7 40099a03 (Gentoo Viking2
Samba Server)
Comment 1 Michael Hamilton 2006-05-03 17:34:52 EDT
Created attachment 128569 [details]
Dmesg from latest boot - to document current system config.
Comment 2 Dave Jones 2006-05-06 20:09:56 EDT

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.