Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1906479

Summary: fluentforward inability to connect blocks fluent pods from starting
Product: OpenShift Container Platform Reporter: Jeff Cantrill <jcantril>
Component: LoggingAssignee: Jeff Cantrill <jcantril>
Status: CLOSED ERRATA QA Contact: Giriyamma <gkarager>
Severity: medium Docs Contact:
Priority: high    
Version: 4.6CC: anli, aos-bugs
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: logging-core
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: When forward outputs is configured but the output is not resolvable Consequence: it will cause the fluent pod to fail starting which will block all logforwarding Fix: sets the fluentd forward heartbeat to "none" Result: The pod is able to start without error
Story Points: ---
Clone Of: 1901096 Environment:
Last Closed: 2021-02-22 13:46:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1901096    
Bug Blocks:    

Comment 3 Giriyamma 2021-02-16 10:22:45 UTC
Verified with clusterlogging.4.6.0-202102130420.p0, issue is fixed.

Comment 5 errata-xmlrpc 2021-02-22 13:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.18 extras update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0512