Bug 1906489 - [DDF] systemd-resolved doesn't appear in the technology preview section of the release notes for any RHEL release
Summary: [DDF] systemd-resolved doesn't appear in the technology preview section of th...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: Documentation
Version: 8.0
Hardware: All
OS: All
medium
unspecified
Target Milestone: rc
: 8.0
Assignee: Lucie Maňásková
QA Contact:
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-10 16:11 UTC by Direct Docs Feedback
Modified: 2021-03-25 15:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Technology Preview
Doc Text:
.The `systemd-resolved` service is now available as a Technology Preview The `systemd-resolved` service provides name resolution to local applications. The service implements a caching and validating DNS stub resolver, an Link-Local Multicast Name Resolution (LLMNR), and Multicast DNS resolver and responder. Note that, even if the `systemd` package provides `systemd-resolved`, this service is an unsupported Technology Preview.
Clone Of:
Environment:
Last Closed: 2021-02-16 12:08:50 UTC
Type: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3771891 0 None None None 2020-12-10 16:49:58 UTC

Description Direct Docs Feedback 2020-12-10 16:11:09 UTC
systemd-resolved doesn't appear in the technology preview section of the release notes for any RHEL release

Reported by: jconti

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/configuring_and_managing_networking/using-different-dns-servers-for-different-domains_configuring-and-managing-networking#annotations:c57bd97b-8bf6-4105-af28-3ecc6732dd98

Comment 2 James Hartsock 2020-12-10 16:50:00 UTC
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/configuring_and_managing_networking/using-different-dns-servers-for-different-domains_configuring-and-managing-networking

>IMPORTANT
>In RHEL 8, Red Hat provides systemd-resolved as an unsupported Technology Preview.

---

Looking RHEL 8 release notes only mentions of systemd-resolved I see are in RHEL 8.1 & 8.2 has mention of systemd-resolved in known issues
  https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/8.1_release_notes/rhel-8_1_0_release#known-issue_shells-and-command-line-tools
  https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/8.2_release_notes/known-issues#known-issue_shells-and-command-line-tools

And is definitely NOT mentioned in the RHEL 8.3 Network Technology Preview section
   https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/8.3_release_notes/technology_previews#technology-preview_networking


Furthermore, we have the following that states systemd-resolved is supported!
   https://access.redhat.com/solutions/3771891


Appears this may just be a Tech Preview note that was left in the Configure & Managing Networking RHEL 8 Documentation.  Can we please get confirmation?

Comment 3 Marc Muehlfeld 2020-12-14 08:21:28 UTC
Lukas, can you please confirm that systemd-resolved is fully supported in RHEL 8 or that it's Tech Preview?
If it is supported, which RHEL 8 version was the first one, in which we fully supported it?

Comment 4 Lukáš Nykrýn 2021-01-14 16:03:50 UTC
It really should be just a tech preview in rhel8.

Comment 5 James Hartsock 2021-01-14 16:11:03 UTC
So what does this mean for customers that are using it thinking that it is supported since it is not in any of the RHEL 8 minor version Release Notes - Tech Preview section?

I think this is the location that most feel is authoritative for anything that is provided as Tech Preview in a given RHEL release.

Comment 6 Marc Muehlfeld 2021-01-14 16:17:26 UTC
Lukas Nykryn confirmed on Red Hat-internal IRC that systemd-resolved is Tech Preview in RHEL 8.

I already updated the KCS article: https://access.redhat.com/solutions/3771891

Tomorrow I'll write a Tech Preview RN and add it to the RHEL 8.x Release Notes documents.

Comment 7 James Hartsock 2021-01-14 17:32:48 UTC
Would be nice if the systemd-resolved.service had an ExecPre= or something that did the following too:
  /bin/echo 29 > /proc/sys/kernel/tainted

Would make it clear for customers, and we have it documented at:
  https://access.redhat.com/solutions/40594

Comment 8 James Hartsock 2021-01-14 17:34:18 UTC
Guess that would need to be, right?
  echo 536870912

Comment 12 Marc Muehlfeld 2021-01-18 13:38:42 UTC
Lucie, can you please add the RN from the Doc Text field to the Tech Preview sections in the RHEL 8.0 - 8.3 Release Notes documents? It is missing there. Thanks.


Note You need to log in before you can comment on or make changes to this bug.