Bug 190655 - Spec file fixes and enhancements for hal
Summary: Spec file fixes and enhancements for hal
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix, Patch
: 160633 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-04 09:37 UTC by Matthias Saou
Modified: 2013-03-06 03:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 13:59:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (4.67 KB, patch)
2006-05-04 09:40 UTC, Matthias Saou
no flags Details | Diff

Description Matthias Saou 2006-05-04 09:37:53 UTC
Attached is a spec file patch for hal, which fixes a few issues :
- hal was owning many directories under /usr/share/locale/ which is wrong, so
  now use %find_lang to properly handle that
- some build requirements were missing
- the build root wasn't getting cleaned right before make install

Other minor stuff :
- tabs vs. spaces
- order of the sub-packages for the %files section
- simplify the "%dir foo + foo/*" into "foo/" in %files

There was also a strange "z#fi" at the end of %post... about to bite?

Comment 1 Matthias Saou 2006-05-04 09:40:02 UTC
Created attachment 128592 [details]
Spec file patch

Comment 2 Reuben Farrelly 2006-05-20 10:10:07 UTC
Poke for this - can at least the z#fi error be fixed in the %post script ?


Comment 3 Matthias Clasen 2006-09-10 18:16:06 UTC
*** Bug 160633 has been marked as a duplicate of this bug. ***

Comment 4 Matthias Saou 2007-02-05 13:59:54 UTC
Closing as DEFERRED since all these fixes and enhancements, if not already
fixed, should be caught during the Core+Extras merger review process.


Note You need to log in before you can comment on or make changes to this bug.