Bug 1906649 - [release-4.6] The quota controllers should resync on new resources and make progress
Summary: [release-4.6] The quota controllers should resync on new resources and make p...
Keywords:
Status: CLOSED DUPLICATE of bug 1904028
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Lukasz Szaszkiewicz
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1904028
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-11 03:01 UTC by OpenShift BugZilla Robot
Modified: 2020-12-11 08:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-11 08:25:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description OpenShift BugZilla Robot 2020-12-11 03:01:47 UTC
+++ This bug was initially created as a clone of Bug #1904028 +++

+++ This bug was initially created as a clone of Bug #1904026 +++

The quota controllers act on resources retrieved from the discovery endpoint which might contain only a fraction of all resources due to a network error.

Both controllers should periodically resync when new resources are observed from the discovery.

Additionally, the CRQ should always ensure the current set of monitors are running.
The CRQ should not block when new resources are observed (deadlock).

Comment 1 Lukasz Szaszkiewicz 2020-12-11 08:25:10 UTC

*** This bug has been marked as a duplicate of bug 1904028 ***


Note You need to log in before you can comment on or make changes to this bug.