Bug 19068 - g++ crahes when compiling lyx
g++ crahes when compiling lyx
Status: CLOSED DUPLICATE of bug 18166
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
ftp://ftp.lyx.org/pub1/lyx/stable/lyx...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 14:07 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 14:00:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-13 14:07:04 EDT
After running configure and running make g++ crashes on the first source
file is has to compile (formula.C)

/usr/include/g++-3/sstream:163: no `int std::stringbuf::sync ()' member
function declared in class `std::stringbuf'
/usr/include/g++-3/sstream: In method `int std::stringbuf::sync ()':
/usr/include/g++-3/sstream:167: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

The following g++ flags are used: -g -O2 -fhonor-std

By removing the -fhonor-std flag I can stop g++ from crashing but the
source still can't be compiled. g++ aborts starting with the following
errors:

In file included from /usr/include/g++-3/sstream:31,
                 from ../../src/support/lstrings.h:16,
                 from ../../src/debug.h:10,
                 from ../../src/commandtags.h:14,
                 from formula.C:31:
/usr/include/g++-3/string:9: conflicting types for `typedef class 
basic_string<char, string_char_traits<char>, 
__default_alloc_template<true, 0> > string'

This first errormessage is followed by a fews screens of other messages.
Comment 1 Need Real Name 2000-10-18 14:00:56 EDT
Got lyx to compile without any errors. I ran configure on a RH6.2 system and
transfered the code to my RH7.0 machine.
I typed make and behold lyx compiles without any errors.
Looks like the lyx configure scripts has some problems on RH7.0, or RH7.0 has
some problems :-)
But the g++ compiler should not crash on the lyx code even if not configured
correctly. 
I haven't checked yet if the compiled code runs ok.
Comment 2 Need Real Name 2000-10-19 16:13:54 EDT

*** This bug has been marked as a duplicate of 18166 ***

Note You need to log in before you can comment on or make changes to this bug.