Bug 1906811 - python-absl-py fails to build with Python 3.10: setup.py detects Python 3.1 instead of Python 3.10
Summary: python-absl-py fails to build with Python 3.10: setup.py detects Python 3.1 i...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-absl-py
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: code
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-11 13:29 UTC by Tomáš Hrnčiar
Modified: 2020-12-11 15:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-11 15:48:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-12-11 13:29:22 UTC
python-absl-py fails to build with Python 3.10.0a3.

This seems like a problem with detecting the correct version of Python (3.10 instead of 3.1). 

You can use (something like) this instead: 
 
$ python3.10 -c "import sys; sys.stdout.write('{}.{}'.format(*sys.version_info[:2]))" 
3.10

py_version = platform.python_version_tuple()
if py_version < ('2', '7') or py_version[0] == '3' and py_version < ('3', '4'):
   raise RuntimeError('Python version 2.7 or 3.4+ is required.')

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01824033-python-absl-py/

For all our attempts to build python-absl-py with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-absl-py/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 code 2020-12-11 15:48:01 UTC
Thanks, this is useful. I have fixed this in Rawhide with a trivial patch in 0.11.0-4, and submitted an upstream report at https://github.com/abseil/abseil-py/issues/161.

It’s mildly surprising that string-based version detection made it through code review at A Large Internet Company in the first place, especially in their foundational Python library.


Note You need to log in before you can comment on or make changes to this bug.