Bug 1906852 - python-colcon-cmake fails to build with Python 3.10: ImportWarning: VendorImporter.exec_module() not found; falling back to load_module()
Summary: python-colcon-cmake fails to build with Python 3.10: ImportWarning: VendorImp...
Keywords:
Status: CLOSED DUPLICATE of bug 1911607
Alias: None
Product: Fedora
Classification: Fedora
Component: python-colcon-cmake
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott K Logan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1911607
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-11 14:51 UTC by Tomáš Hrnčiar
Modified: 2021-01-08 12:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-08 12:30:50 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github pypa setuptools issues 2481 0 None open [Forward compatibility][BUG] `pkg_resources.extern.VendorImporter` lacks `exec_module()` method 2021-01-08 12:37:20 UTC

Description Tomáš Hrnčiar 2020-12-11 14:51:05 UTC
python-colcon-cmake fails to build with Python 3.10.0a3.

==================================== ERRORS ====================================
______________ ERROR collecting test/test_parse_cmake_version.py _______________
test/test_parse_cmake_version.py:4: in <module>
    from colcon_cmake.task.cmake import _parse_cmake_version_string
colcon_cmake/task/cmake/__init__.py:12: in <module>
    from pkg_resources import parse_version
/usr/lib/python3.10/site-packages/pkg_resources/__init__.py:73: in <module>
    from pkg_resources.extern import appdirs
<frozen importlib._bootstrap>:1026: in _find_and_load
    ???
<frozen importlib._bootstrap>:1005: in _find_and_load_unlocked
    ???
<frozen importlib._bootstrap>:681: in _load_unlocked
    ???
E   ImportWarning: VendorImporter.exec_module() not found; falling back to load_module()
=========================== short test summary info ============================
ERROR test/test_parse_cmake_version.py - ImportWarning: VendorImporter.exec_m...
!!!!!!!!!!!!!!!!!!!! Interrupted: 1 error during collection !!!!!!!!!!!!!!!!!!!!
=============================== 1 error in 0.20s ===============================

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01824051-python-colcon-cmake/

For all our attempts to build python-colcon-cmake with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-colcon-cmake/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Scott K Logan 2020-12-11 22:38:57 UTC
I've added the upstream ticket tracking this issue in setuptools. There is a workaround to get the tests passing, but the ticket is fairly fresh, and I'd like to give it some time to mature.

Comment 2 Miro Hrončok 2021-01-08 12:30:50 UTC

*** This bug has been marked as a duplicate of bug 1911607 ***


Note You need to log in before you can comment on or make changes to this bug.