Bug 1906854 - python-colcon-ros fails to build with Python 3.10: ImportWarning: VendorImporter.exec_module() not found; falling back to load_module()
Summary: python-colcon-ros fails to build with Python 3.10: ImportWarning: VendorImpor...
Keywords:
Status: CLOSED DUPLICATE of bug 1911607
Alias: None
Product: Fedora
Classification: Fedora
Component: python-colcon-ros
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott K Logan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1911607
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-11 14:53 UTC by Tomáš Hrnčiar
Modified: 2021-01-08 12:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-08 12:34:16 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github pypa setuptools issues 2481 0 None closed [Forward compatibility][BUG] `pkg_resources.extern.VendorImporter` lacks `exec_module()` method 2021-02-10 09:38:16 UTC

Description Tomáš Hrnčiar 2020-12-11 14:53:55 UTC
python-colcon-ros fails to build with Python 3.10.0a3.

==================================== ERRORS ====================================
______________ ERROR collecting test/test_dependency_metadata.py _______________
test/test_dependency_metadata.py:6: in <module>
    from colcon_ros.package_identification.ros import _create_metadata
colcon_ros/package_identification/ros.py:7: in <module>
    from colcon_core.package_augmentation import PackageAugmentationExtensionPoint
<frozen importlib._bootstrap>:1026: in _find_and_load
    ???
<frozen importlib._bootstrap>:1005: in _find_and_load_unlocked
    ???
<frozen importlib._bootstrap>:698: in _load_unlocked
    ???
/usr/lib/python3.10/site-packages/_pytest/assertion/rewrite.py:170: in exec_module
    exec(co, module.__dict__)
/usr/lib/python3.10/site-packages/colcon_core/package_augmentation/__init__.py:10: in <module>
    from colcon_core.plugin_system import instantiate_extensions
<frozen importlib._bootstrap>:1026: in _find_and_load
    ???
<frozen importlib._bootstrap>:1005: in _find_and_load_unlocked
    ???
<frozen importlib._bootstrap>:698: in _load_unlocked
    ???
/usr/lib/python3.10/site-packages/_pytest/assertion/rewrite.py:170: in exec_module
    exec(co, module.__dict__)
/usr/lib/python3.10/site-packages/colcon_core/plugin_system.py:7: in <module>
    from colcon_core.entry_point import load_entry_points
<frozen importlib._bootstrap>:1026: in _find_and_load
    ???
<frozen importlib._bootstrap>:1005: in _find_and_load_unlocked
    ???
<frozen importlib._bootstrap>:698: in _load_unlocked
    ???
/usr/lib/python3.10/site-packages/_pytest/assertion/rewrite.py:170: in exec_module
    exec(co, module.__dict__)
/usr/lib/python3.10/site-packages/colcon_core/entry_point.py:12: in <module>
    from pkg_resources import iter_entry_points
/usr/lib/python3.10/site-packages/pkg_resources/__init__.py:73: in <module>
    from pkg_resources.extern import appdirs
<frozen importlib._bootstrap>:1026: in _find_and_load
    ???
<frozen importlib._bootstrap>:1005: in _find_and_load_unlocked
    ???
<frozen importlib._bootstrap>:681: in _load_unlocked
    ???
E   ImportWarning: VendorImporter.exec_module() not found; falling back to load_module()

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01824058-python-colcon-ros/

For all our attempts to build python-colcon-ros with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-colcon-ros/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Scott K Logan 2020-12-11 22:36:34 UTC
I've added the upstream ticket tracking this issue in setuptools. There is a workaround to get the tests passing, but the ticket is fairly fresh, and I'd like to give it some time to mature.

Comment 2 Miro Hrončok 2021-01-08 12:34:16 UTC

*** This bug has been marked as a duplicate of bug 1911607 ***


Note You need to log in before you can comment on or make changes to this bug.