Bug 19069 - update agent fatal error
update agent fatal error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 14:20 EDT by M Katzman
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-24 16:24:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M Katzman 2000-10-13 14:20:39 EDT
re: update agent

When we run the update agent on our newly installed RHL7 it checks
packages, retreive headers and then dies - There was a fatal error
communicating with the server.  The message was: Unable to access RPM
package: ['sysstat', '3.2.4', '4'"].

We hit OK,  the whole thing closes up and is gone.  Tried a few times, 
tried after a re-boot, no change.

We are on a PPro233,  intel m/b,  SMC (tulip) eth.  Browsing is 100% over
ADSL.  Nothing other than clean install of Linux yesterday on this system. 
What else might you want to know?
If he remembers the details East-Coast-Chris might be able to answer any
questions if you have - (he and the rest of the installation support team
have been great with their level of knowledge and attitude - we thank
them).  We are listed under "mkatzman".

e-mail you have,  phone 416.224.5115 x 240

Thanks in advance.

Paul
Comment 1 Cristian Gafton 2000-10-17 18:53:10 EDT
Can you try it again now? I think were connecting to the RHN servers while we
were in the process of updating the errata listing and you might have got a bad
index.
Comment 2 James Ralston 2000-10-20 21:35:01 EDT
I do not believe this is/was a temporary problem, as I've been encountering the
same problem for about a week now.

To reproduce it, all I have to do is to run up2date when I have updates, select
at least one package to update, and click on "Next".  During the "Retrieving
Packages" phase, after the first package is downloaded, up2date bombs out with:

Traceback (innermost last):
  File "/usr/share/rhn/up2date/gui.py", line 350, in doRetrieval
    self.setProgress)
  File "/usr/share/rhn/up2date/up2date.py", line 527, in getPackage
    raise CommunicationError(f.faultString)
up2date.CommunicationError: Error communicating with server.  The message was:
Invalid RPM package requested:
/var/up2date/packages/7.0/src/apache-1.3.14-2.*.rpm

However, *sometimes* it does actually work.  So far, I haven't been able to
discern any pattern in anything I do during successful runs versus unsuccessful
runs.

I can work around this problem by using "up2date -l" to get the package list,
and then downloading and installing them myself.  (I always do the installs
myself, because I want to know what scripts and triggers a package contains.)
But it would be nice to have a solution for this.
Comment 3 Need Real Name 2000-10-23 19:48:51 EDT
I'm having exactly the same problem, both with up2date as distributed with Rh7
and with
the updated up2date-2.0.6-1.
Comment 4 Idcmp 2000-11-24 16:24:29 EST
Ignoring for a moment that a leap of faith is needed to figure out that up2date
has
anything to do with the "RHN Registration" icon my desktop,  upon running
it I get the following error dialog:

 There was a fatal error communicating with the server.  The message was:
  Unable to access RPM package: ['modutils','2.3.20','1','']

I click okay and everything disappears.
Comment 5 Preston Brown 2000-12-27 16:47:59 EST
there was a problem with the server side code for retrieving source .rpm 
packages.  It has been fixed.

Note You need to log in before you can comment on or make changes to this bug.