Bug 1907417 - CSV installation never get completed
Summary: CSV installation never get completed
Keywords:
Status: CLOSED DUPLICATE of bug 1907381
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.7
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: ---
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-14 13:36 UTC by Nahshon Unna-Tsameret
Modified: 2020-12-14 19:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-14 19:14:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nahshon Unna-Tsameret 2020-12-14 13:36:08 UTC
Description of problem:

Trying to deploy an operator and it installed and become ready, but the CSV installation never done and eventually failed for timeout.

The reason for that is where there is a template annotation not the same as the same CSV annotation, with different value.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install a CSV /w a template with a "annotations.description" different than the CSV "annotations.description"; An example is this index-image: 
> quay.io/nunnatsa/hyperconverged-cluster-index:1.3.0 channel=1.3.0
where the CNAO template is with description annotation.

Actual results:
CSV never become successfully installed, and eventually failed for timeout.

Expected results:
CSV is successfully installed after a while


Additional info:
The O relevant OLM code is here: https://github.com/operator-framework/operator-lifecycle-manager/blob/4b66803055a8ab611447c33ed86e755ad39cb313/pkg/controller/install/deployment.go#L263-L269


Note You need to log in before you can comment on or make changes to this bug.