Bug 190747 - Win modifier key doesn't always work as a modifier
Win modifier key doesn't always work as a modifier
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 17:02 EDT by Steve Meyers
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 12:22:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xev log file (3.70 KB, text/plain)
2006-05-04 17:02 EDT, Steve Meyers
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7008 None None None Never

  None (edit)
Description Steve Meyers 2006-05-04 17:02:46 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: fairly random


Steps to Reproduce:
1. Log in graphically (I'm using KDE)
2. Use a key combination including the Win key (e.g. Win+L)
3. If it doesn't reproduce, log out and go to step 1 until it does
  
Actual results:

L

Expected results:

Win+L

Additional info:

In the attached xev log, I did the following (and separated each out with extra
white space):

 - 2
 - Win (left)
 - Win+2
 - Alt
 - Alt+2

As you can see, the Win key is not changing the modifier state -- it's still
0x10.  It should be 0x50.  The Alt key works correctly, changing the state to 0x18.
Comment 1 Steve Meyers 2006-05-04 17:02:46 EDT
Created attachment 128631 [details]
xev log file
Comment 2 Mike A. Harris 2006-05-23 10:15:37 EDT
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 4 James Ralston 2007-01-04 18:51:58 EST
External Bugzilla reference was added some time ago...
Comment 5 James Ralston 2007-01-04 18:53:47 EST
Steve, as the reporter, you are (apparently) the only one who can update the bug
status from NEEDINFO to ASSIGNED...
Comment 6 Steve Meyers 2007-01-04 19:01:56 EST
I don't see a way to do that, but perhaps checking the "I am providing the
requested information for this bug" will help. :)
Comment 7 Matěj Cepl 2007-01-08 16:27:28 EST
Well, the checking of the checkbox would certainly help, but I can do something
as well.
Comment 8 Matthew Miller 2007-04-10 12:22:49 EDT
Since the upstream reference was added, marking closed:upstream.

Note You need to log in before you can comment on or make changes to this bug.