Bug 1907573 - Image operating system mismatch
Summary: Image operating system mismatch
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.4
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: ---
: 4.4.z
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard: pre-merge-verified
: 1899820 (view as bug list)
Depends On: 1868401
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-14 18:05 UTC by OpenShift BugZilla Robot
Modified: 2021-03-08 18:03 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Buildah erased image architecture and OS fields on images Consequence: Common container tools will fail because the resulting images do not identify their architecture and OS. Fix: Buildah does not overwrite the image and architecture unless there are explicit overrides. Result: Resulting images always have architecture and OS fields, and the image mismatch warning does not appear.
Clone Of:
Environment:
Last Closed: 2021-03-08 18:03:56 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift builder pull 198 0 None closed Bug 1907573: Update buildah to v1.14.11 2021-02-16 15:18:56 UTC

Comment 1 Adam Kaplan 2020-12-14 18:09:44 UTC
*** Bug 1899820 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.