Bug 1907807 - 'hammer host puppetrun' (deprecated) not marked as deprecated in hammer
Summary: 'hammer host puppetrun' (deprecated) not marked as deprecated in hammer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.9.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: 6.9.0
Assignee: Dominik Matoulek
QA Contact: Vladimír Sedmík
URL:
Whiteboard:
Depends On:
Blocks: 1905096
TreeView+ depends on / blocked
 
Reported: 2020-12-15 09:48 UTC by Vladimír Sedmík
Modified: 2021-07-28 09:58 UTC (History)
9 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_foreman-2.3.1,foreman-2.3.1.5-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-21 14:10:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 31536 0 Normal Closed 'hammer host puppetrun' (deprecated) not marked as deprecated in hammer 2021-02-01 03:26:26 UTC
Foreman Issue Tracker 31543 0 Normal Closed Improve /puppetrun error message 2021-02-02 11:56:42 UTC
Red Hat Product Errata RHBA-2021:1314 0 None None None 2021-04-21 14:10:53 UTC

Description Vladimír Sedmík 2020-12-15 09:48:22 UTC
Description of problem:
The puppetrun functionality was deprecated in 6.9.0. However, hammer still shows original help for the puppetrun subcommand and 'not implemented' for invocation.


Version-Release number of selected component (if applicable):
6.9.0 snap 5


How reproducible:
always


Steps to Reproduce:
1. # hammer host puppetrun --help
Usage:
    hammer host puppetrun [OPTIONS]

Options:
 --id ID                                  
 --location[-id|-title]                  Set the current location context for the request. Name/Title/Id can be used
 --name NAME                             Name to search by
 --organization[-id|-title]              Set the current organization context for the request. Name/Title/Id can be used
 -h, --help                              Print help

2. # hammer host puppetrun --organization-id 1 --location-id 1 --id 2
Error: 501 Not Implemented


Actual results:
1. shows original help
2. shows 'Not implemented'


Expected results:
1. and 2. should show information about deprecation.

Comment 2 Dominik Matoulek 2020-12-21 12:38:33 UTC
Created redmine issue https://projects.theforeman.org/issues/31536 from this bug

Comment 3 Bryan Kearney 2020-12-24 21:38:47 UTC
Upstream bug assigned to dmatoule@redhat.com

Comment 4 Bryan Kearney 2020-12-24 21:38:49 UTC
Upstream bug assigned to dmatoule@redhat.com

Comment 5 Bryan Kearney 2021-01-19 14:35:57 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/31536 has been resolved.

Comment 12 errata-xmlrpc 2021-04-21 14:10:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Satellite 6.9 Satellite Tools Release), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1314


Note You need to log in before you can comment on or make changes to this bug.