Bug 190788 - Satellite tries to reinstall on multihomed system after kickstarting a client
Satellite tries to reinstall on multihomed system after kickstarting a client
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
400
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Mike McCune
Beth Nackashi
:
Depends On:
Blocks: rhn410-kickstart
  Show dependency treegraph
 
Reported: 2006-05-05 02:38 EDT by Roel Gloudemans
Modified: 2007-07-31 11:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 17:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roel Gloudemans 2006-05-05 02:38:50 EDT
Description of the problem:
We have done a succesful satellite installation and synchronisation. The system
we use has 2 network interfaces, one exposed to the global user lan. This
interface is registered in DNS and is used for the RHN website. The other
interface is on the management LAN and is not registered in DNS. This interface
is also used for kickstarting system.

The URL for the kickstart is based on the IP address of the interface. Now when
you try to login to the satellite (RHN website) after a kickstart, you get
confronted with the installation interface. No matter what you do, the satellite
insists on being installed.

Since this bug is blocking rollout of at least 60 systems it is critical for us
that it get's solved.


Version-Release number of selected component (if applicable):
Satellite server 4.0.6 running on RHEL AS 3 Update 6

How reproducible:
Eacht time


Steps to Reproduce:
1.Install satellite using DNS name
2.Kickstart from IP number
3.Try to login to the RHN website
  
Actual results:
Satellite wants to be installed again

Expected results:
Normal login screen
Comment 5 Vlady Zlatkin 2006-07-03 17:48:32 EDT
I don't understand this bug 100%, but I'll try to write a testplan so this can
be tested.

-find a machine with multiple nics. 
-disable the second nic, give an ip and dns name to the first
(if you set it to dhcp in our lab this will work automatically, dhcp36-xxx)
-install a satellite using this hostname
-bring up the second nic
(does this nic need to be on a different subnet?)
(why does it matter that the second ip does not have an associated hostname?)
-create a kickstart profile, for the distribution url use the ip of the second
nic and not the default hostname 
-kickstart a machine to that profile
-goto the webui
Comment 8 Beth Nackashi 2006-07-05 18:43:41 EDT
moving to verified -- accessing the satellite UI via the IP address of the
second ethernet device no longer brings up the installer UI
Comment 9 Beth Nackashi 2006-07-19 17:06:52 EDT
moving to closed - currentrelease

Note You need to log in before you can comment on or make changes to this bug.