Bug 190829 - FC5 Install failure on Crusoe processor: incorrect arch
FC5 Install failure on Crusoe processor: incorrect arch
Status: CLOSED DUPLICATE of bug 186378
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 11:50 EDT by Chris Rigsby
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 12:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rigsby 2006-05-05 11:50:43 EDT
Description of problem:
Attempting to install Fedora Core 5 on a computer with a Transmeta Crusoe TM5800
processor.  This machine has run RedHat 8, 9, and Fedora Core 4 with no issues
during installation.  During the installation, the following error appears on
the graphical screen:

"There was an error running your transactions for the following reason(s):
package for incorrect arch"

Switching to virtual terminal 3, the log shows that this disk partition/prep
process has completed, and attempts were made to install three packages, all
with same error:
* error running transaction: package glibc-2.4-4 is intended for i686 architecture
* error running transaction: package openssl-0.9.8a-5.2 is intended for i686
architecture
* error running transaction: package kernel-2.6.15-1.2054_FC5 is intended for
i686 architecture

The installation is assuming that the machine is of the i686 platform type, but
fails when attempting to install packages for that platform.

Again, this behavior is new and different in comparison to Fedora Core 4.  I did
not encounter this error with FC4.

Version-Release number of selected component (if applicable):
Fedora Core 5

How reproducible:
To reproduce, you would need to have a Crusoe-based system, such as this Fujitsu
P2120, or a Sony VIAO PCG-U3 (see posting on FedoraForum at
http://www.fedoraforum.org/forum/archive/index.php/t-103701.html ).

Steps to Reproduce:
1. Boot system with installation media of choice
2. Accept all defaults
3. After disk partioning and prep is completed, package installs will fail
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Rigsby 2006-05-05 12:07:33 EDT
Sorry, my original search missed the existing case on exactly this issue.  My
apologies.

*** This bug has been marked as a duplicate of 186378 ***

Note You need to log in before you can comment on or make changes to this bug.