Bug 1908463 - OLM continuously printing debug logs
Summary: OLM continuously printing debug logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Alexander Greene
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1908436 (view as bug list)
Depends On: 1903034
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-16 18:57 UTC by OpenShift BugZilla Robot
Modified: 2021-02-01 15:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-01 15:24:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1910 0 None closed Bug 1908463: Reduce log noise from OLM 2021-02-03 09:34:12 UTC
Red Hat Product Errata RHBA-2021:0235 0 None None None 2021-02-01 15:24:55 UTC

Comment 1 Kevin Rizza 2020-12-16 18:58:59 UTC
*** Bug 1908436 has been marked as a duplicate of this bug. ***

Comment 6 Jian Zhang 2021-01-22 07:42:45 UTC
Cluster version is 4.6.0-0.nightly-2021-01-21-220319
[root@preserve-olm-env data]# oc -n openshift-operator-lifecycle-manager  exec catalog-operator-6d78875646-s4stq -- olm --version
OLM version: 0.16.1
git commit: 09f6590a10e4925e7382e1a389c002d761e341fb


1, Install two cluster-scoped operators, and there are no DEBUG level logs in the olm logs. 
[root@preserve-olm-env data]# oc get sub -A
NAMESPACE             NAME                              PACKAGE                           SOURCE                CHANNEL
openshift-operators   akka-cluster-operator-certified   akka-cluster-operator-certified   certified-operators   beta
openshift-operators   etcd                              etcd                              community-operators   clusterwide-alpha


[root@preserve-olm-env data]# oc get pods
NAME                                READY   STATUS    RESTARTS   AGE
catalog-operator-6d78875646-s4stq   1/1     Running   0          46m
olm-operator-56644cfc55-nnm2b       1/1     Running   0          46m
packageserver-54dbc84cdf-9286c      1/1     Running   0          38m
packageserver-54dbc84cdf-j9bdx      1/1     Running   0          38m
[root@preserve-olm-env data]# oc logs catalog-operator-6d78875646-s4stq > catalog.22
[root@preserve-olm-env data]# ls -lh catalog.22
-rw-r--r--. 1 root root 64K Jan 22 07:26 catalog.22


[root@preserve-olm-env data]# cat catalog.22 |grep -i debug
[root@preserve-olm-env data]# 

LGTM, verify it.

Comment 9 errata-xmlrpc 2021-02-01 15:24:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0235


Note You need to log in before you can comment on or make changes to this bug.