Bug 190849 - versions starting with v or v.
versions starting with v or v.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cpanspec (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
http://search.cpan.org/~kclark/Text-R...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 14:06 EDT by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 18:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strip leading "v" from rpm version (760 bytes, patch)
2006-05-05 17:47 EDT, Steven Pritchard
no flags Details | Diff
strip leading "v" from rpm version (766 bytes, patch)
2006-05-05 17:49 EDT, Steven Pritchard
no flags Details | Diff

  None (edit)
Description Roy-Magne Mo 2006-05-05 14:06:13 EDT
Description of problem:
cpanspec parses version numbers starting with 'v' and concludes that this should
be a part of the version number for the rpm packages. This could be both
considered as a bug and a feature :)

Version-Release number of selected component (if applicable):
cpanspec-1.65-1.fc5

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I would like cpanspec to parse the package versions and split of the the first v
or v. from the package - do you agree? 

The package in the URL shows this behaviour.
Comment 1 Steven Pritchard 2006-05-05 17:45:22 EDT
I'd argue that this is a bug in the upstream package, since it is different than
every other package on CPAN that I have looked at.

Looking more closely, there appears to be one package on CPAN that uses "v." in
the file name, and something like 75 that use "V" or "v".

While I'm not crazy about supporting this, it seems to be easy enough.  Try the
attached patch.  It seems obvious enough that I will apply it to the next
release, but I'd appreciate some feedback.
Comment 2 Steven Pritchard 2006-05-05 17:47:03 EDT
Created attachment 128681 [details]
strip leading "v" from rpm version
Comment 3 Steven Pritchard 2006-05-05 17:49:54 EDT
Created attachment 128682 [details]
strip leading "v" from rpm version

Safer regex.
Comment 4 Roy-Magne Mo 2006-05-05 18:38:15 EDT
(In reply to comment #1)
> I'd argue that this is a bug in the upstream package, since it is different than
> every other package on CPAN that I have looked at.
> 
> Looking more closely, there appears to be one package on CPAN that uses "v." in
> the file name, and something like 75 that use "V" or "v".
> 
> While I'm not crazy about supporting this, it seems to be easy enough.  Try the
> attached patch.  It seems obvious enough that I will apply it to the next
> release, but I'd appreciate some feedback.


I completely agree with you that this is a bug in the upstream package, but I
also believe that the time invested in making cpanspec more liberal would be
minimal compared to trying to get all those packages fixed :) 

I tried building one package that shows this problem, works as expected.

This package also has another problem, the $VERSION doesn't get picked up
correctly - but that is a problem of rpm. I registered a bug against it in
rt.cpan.org

Comment 5 Steven Pritchard 2006-05-05 18:55:32 EDT
That sounds like bug 140597.  Does the patch included there fix the problem?
Comment 6 Roy-Magne Mo 2006-05-05 19:30:20 EDT
(In reply to comment #5)
> That sounds like bug 140597.  Does the patch included there fix the problem?

No, this is http://rt.cpan.org/Public/Bug/Display.html?id=19103 - a different
matter. I don't think perl could pick up these things reliably unless it's
starts evaling.

Note You need to log in before you can comment on or make changes to this bug.