Bug 190859 - Printers added with spadmin don't appear in print dialogue
Printers added with spadmin don't appear in print dialogue
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 15:06 EDT by David Kaplan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.2-5.12.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 03:35:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2006-05-05 15:06:17 EDT
Description of problem:
I added a PDF converter with spadmin and it does not appear in the print
dialogue of openoffice (probably because this is now done through gnome-print).
 The pdf converter is useful even though export to PDF exists because of another
bug with export to pdf which I will report shortly (basically, does not handle
embedded postscript images correctly).

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.2-5.7.2

How reproducible:
always

Steps to Reproduce:
1.create a printer with spadmin as root
2.open a document and try to print to that printer
3.
  
Actual results:
printer not in print dialogue

Expected results:
should be there.

Additional info:
Comment 1 Caolan McNamara 2006-05-10 07:52:53 EDT
This simply conflicts with using the native GNOME/Gtk print dialogs. There's no
way around it, either the native dialogs are used and there's no ability to have
the custom psprint one, or the built-in one is used.

I guess the best I can do is to make it possible to toggle using the built-in
dialog in a pinch.

Or fix the pdf eps inclusion so the workaround of using the spadmin (which we're
trying to deprecate) isn't required
Comment 2 Caolan McNamara 2006-05-20 06:53:27 EDT
For FC-5 we'll revert to the old print dialog, for FC-6 we'll use the new
gtkunixprintdialog and make it togglable on and off with the "use OOo/System
dialogs" option
Comment 3 David Kaplan 2006-05-23 09:17:57 EDT
Sounds like a plan.  Also, in openoffice, in the file menu below print there is
a "printer settings" option that currently takes you to an OOo config dialogue -
this is inconsistent and confusing.
Comment 4 Fedora Update System 2006-05-24 19:25:27 EDT
openoffice.org-2.0.2-5.12.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.