Bug 190861 - no option to print to file with most printers
no option to print to file with most printers
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeprintui22 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 15:21 EDT by David Kaplan
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 11:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2006-05-05 15:21:18 EDT
Description of problem:
When I go to print a document, almost all of the printers listed do not allow
you to print to a file.  The only ones that allow printing to a file are
"Generic Postscript" and "Create a PDF Document".  All the other printers have
not options at Locations.  This seems odd as programs like firefox do allow you
to print to a file using the same printer.  

This is probably a bug in gnome-print or something like that, but it is hard to
tell who the real culprit is.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.2-5.7.2
printman-0.0.1-2.20021202.17

How reproducible:
always

Steps to Reproduce:
1.Open a document
2.Try to print
3.
  
Actual results:
No option to print to a file

Expected results:
Should be possible.

Additional info:
Most of the printers I have available to me are web discovered printers.  There
is, however, one printer managed with HPLIP, but not connected at the time, and
another that is managed by Lexmark's Java based printer software.  Neither of
these allow printing to file either.
Comment 1 Caolan McNamara 2006-05-09 10:50:53 EDT
OOo uses the gnome-print dialog, so the same behaviour is found in all such
gnome-printui using GNOME apps, e.g. gedit. So not a OOo bug/problem. There is
apparently a new GTK print dialog in the works, so the gnome-print one will be
redundant soon in favour the new one.

caolanm->alexl: feature-request for the new gtk print dialog to be able to
choose "print to file" for all printers.
Comment 2 John (J5) Palmieri 2006-05-09 11:00:49 EDT
Not really a bug and I am not even sure it is that useful a feature.  If you
want this feature in the new print dialog going into GTK+ (which will eventually
be added to OOo) I suggest descussing it on the gtk+ devel list.  
Comment 3 David Kaplan 2006-05-23 09:26:32 EDT
This is definitely an important feature because: (1) every other operating
system I have ever used allows it, (2) Generate PDF currently has problems with
embedded EPS images, so the only way to get decent output is to generate a
postscript version and (3) this is absolutely necessary for generating
publication quality figures.  This last point is really important.  A lot of
linux users are in academia and they need to make high quality figures.  Often
PS is the only acceptable format.  OpenOffice + export to PS file was an
excellent way to do this before the new printing dialogue took this feature away.

Note You need to log in before you can comment on or make changes to this bug.