Bug 190883 - rdate does not work with udp packets
rdate does not work with udp packets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rdate (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 17:49 EDT by István Tóth
Modified: 2015-02-01 17:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 12:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wtogami: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description István Tóth 2006-05-05 17:49:20 EDT
Description of problem:

If I try to use an rfc868 time server in udp mode ( in this case the the time
server is the one bundled in xinetd in fc5, running on the same host),
rdate exits with error. Rdate works fine in tcp mode.


Version-Release number of selected component (if applicable):
rdate-1.4-4.2.1

How reproducible:


Steps to Reproduce:
1. enable time-udp, stop iptables
2. rdate -u localhost
3.
  
Actual results:
rdate displays:
rdate: error in read: Invalid argument

Expected results:
rdate displays time


Additional info:

The problem is probably in the client, and not the server, because other devices
can successfully use the udp time service, and an ethereal dump shows a valid
packet sent back to client.

The same test works on a Centos4 server perfectly.
Comment 1 Jiri Moskovcak 2007-07-09 09:07:48 EDT
Package Change Request
======================
Package Name: rdate
Updated Fedora Owners: jmoskovc@redhat.com
Comment 2 István Tóth 2007-07-10 03:58:04 EDT
I've retested with Fedora 7 x86_64, and the bug is fixed there.

I do not have access to an F7 i386 machine to test, unfortunately.
Comment 3 Jiri Moskovcak 2007-07-10 12:58:49 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.